Универсальные печатные формы в управляемой форме

Публикация № 1086584

Печать - Универсальные печатные формы

Печатная форма Макет Табличный документ Консоль запросов Выполнение кода Печать документов.

26
Универсальные печатные формы + Возможность редактировать печатную форму в режиме предприятия на лету + Код заполнения в режиме предприятий + Конструктор запросов и конструктор заполнения областей + Хранит и восстанавливает версий макет и кода заполнения + Легко для изучения и работы не для программистов

Универсальные печатные формы

Плюсы
+ Возможность редактировать печатную форму в режиме предприятия на лету
+ Код заполнения в режиме предприятий
+ Конструктор запросов и конструктор заполнения областей
+ Хранит и восстанавливает версий макет и кода заполнения
+ Легко для изучения и работы не для программистов
+ Легко администрируется.

Минусы
Не обнаружены

Пример печати документов

&НаСервере
Функция ПечатьНаСервере()
	ТабДокПечать = Справочники.УниверсальныеПечатныеФормы.Печать(Объект.Ссылка,Документ);
	Возврат ТабДокПечать;  
КонецФункции


&НаКлиенте
Процедура ТестовыйПечать(Команда)
	Если ЗначениеЗаполнено(Документ) Тогда
		ТабДокПечать = ПечатьНаСервере();
		ТабДокПечать.Показать(Объект.Наименование);
	КонецЕсли;
КонецПроцедуры


Легко устанавливается в любую базу на управляемых формах.

Для создания простых печатных форм вам не потребуется особых знаний программирования. Возможность наложить ответственность на печатные формы аналитикам, администраторам или даже Бухгалтерам.

Тестировался и запускал в версий 1С Предприятие 8.3.10.2580.

26

Скачать файлы

Наименование Файл Версия Размер
Универсальные печатные форма в управляемой форме:
.dt 56,95Kb
03.07.19
7
.dt 56,95Kb 7 Скачать

См. также

Специальные предложения

Автор запретил комментарии