Печать ценников весового товара для 1С: Розница 2.2

Публикация № 1116236

Учет и отчетность - Розничная торговля

4
Обработка формирования ценников для весового товара в Конфигурация 1С: Розница, редакция 2.2 (2.2.9.20).

Обработка формирования Ценников для весового товара в 1С: РОЗНИЦА 2.2

Данная обработка, подключается как внешняя обработка.

Тестировалась на платформе 1С:Предприятие 8.3 (8.3.10.2753)
Конфигурация 1С Розница, редакция 2.2 (2.2.9.20) 

При запуске есть возможность выбрать Весовой товар.

В табличной части заполняется список весового товара в граммах.

Автоматически рассчитывается цена и штрих код.

Для правильного отображения цены, не забудьте для Товара установить через документ "Установка цен номенклатуры" Цену за 1 кг.

На закладке "Ценники для печати" формируются ценники, с возможность печати на принтер. 
 

&НаСервере
Функция ПолучитьКоличествоМиллиметровВПикселе()
	Эталон = Обработки.ПечатьЭтикетокИЦенников.ПолучитьМакет("Эталон");
	КоличествоМиллиметровВПикселе = Эталон.Рисунки.Квадрат100Пикселей.Высота / 100;	
	Возврат КоличествоМиллиметровВПикселе;
КонецФункции

&НаСервере
Процедура СформироватьЦенники()	
	КоличествоМиллиметровВПикселе = ПолучитьКоличествоМиллиметровВПикселе();
	
	ВывелиХотяБыОдинШтрихКод=Ложь;
	
	ВсегоКолонок = Колонок;	
	ВсегоСтрок   = 4;
	
	ТекКолонка = 1;
	ТекСтрока  = 1;
	
	Таб = ТабличныйДокумент1; Таб.Очистить();	
	Таб.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ЦЕННИК";
	
	ЭтотОбъектОбработки=РеквизитФормыВЗначение("Объект");
	Макет =  ЭтотОбъектОбработки.ПолучитьМакет("Макет"); 	

	СтранаПроисхождения = ПолучитьЗначениеУОбъекта(Объект.Номенклатура,"СтранаПроисхождения");	
	Товар=Объект.Номенклатура;	
	ТабличноеПоле1 = Объект.Товары;
	Н=0;
	Для Каждого СтрокаИзСписка Из Объект.Товары Цикл	
		Если СтрокаИзСписка.Вес_В_Граммах=0 Тогда
			Продолжить;
		КонецЕсли;
		Н=Н+1;			
		ШК=СтрокаИзСписка.ШтрихКод;	
		ОбластьЗначение = Макет.ПолучитьОбласть("ВертТело|ГорТело");							
		ОбластьЗначениеМ = Макет.ПолучитьОбласть("ВертТело|Гор_М_Тело");								
		ОбластьЗначениеМпусто = Макет.ПолучитьОбласть("ВертТело|Гор_М_ТелоПусто");										
		
		//************************************
		Попытка
			РисунокШК = ОбластьЗначение.Рисунки.ШтрихКод;		
			Если РисунокШК <> Неопределено Тогда
				Если ПустаяСтрока(ШК) Тогда
					Таб.Рисунки.Удалить(РисунокШК);
				Иначе
					ПараметрыШтрихкода = Новый Структура;
					ПараметрыШтрихкода.Вставить("Ширина",	Окр(РисунокШК.Ширина / КоличествоМиллиметровВПикселе));
					ПараметрыШтрихкода.Вставить("Высота",	Окр(РисунокШК.Высота / КоличествоМиллиметровВПикселе));				
					ПараметрыШтрихкода.Вставить("Штрихкод", ШК);
					ПараметрыШтрихкода.Вставить("ТипКода", 99);
					ПараметрыШтрихкода.Вставить("ОтображатьТекст", Истина);
					ПараметрыШтрихкода.Вставить("Штрихкод", ШК);									
					РисунокШК.Картинка = МенеджерОборудованияВызовСервера.ПолучитьКартинкуШтрихкода(ПараметрыШтрихкода);
				КонецЕсли;
			КонецЕсли;
		Исключение //  не установлен 
			Ошибка = ОписаниеОшибки();
			Сообщить("Не удалось сформировать штрих-код! Подробнее: "+Ошибка);
		КонецПопытки;
				
		//*************************************		
		
		ОбластьЗначение.Параметры.НазваниеТовара = СокрЛП(Товар)+" "+СокрЛП(СтрокаИзСписка.Вес_В_Граммах)+"г";	
		ОбластьЗначение.Параметры.Цена = Формат(СтрокаИзСписка.Цена,"ЧГ=");
		ОбластьЗначение.Параметры.СтранаПроисхождения = СтранаПроисхождения;		
		//~1:
		Если ТекКолонка > ВсегоКолонок Тогда
			ТекКолонка = 1;
			ТекСтрока  = ТекСтрока + 1;
		КонецЕсли;
		
		Если ТекСтрока > ВсегоСтрок Тогда
			ТекСтрока  = 1;
			Таб.ВывестиГоризонтальныйРазделительСтраниц();
		КонецЕсли;
		
		Если ТекКолонка = 1 Тогда
			Таб.Вывести(ОбластьЗначение);
		Иначе
			Таб.Присоединить(ОбластьЗначение);
		КонецЕсли;
		
		ВывелиХотяБыОдинШтрихКод = Истина;	
		ТекКолонка  = ТекКолонка + 1;		
	КонецЦикла;
	
	Если ВывелиХотяБыОдинШтрихКод И ТекСтрока=1 Тогда
	 	Для н=ТекКолонка по Колонок Цикл
			Таб.Присоединить(ОбластьЗначениеМпусто);					
		КонецЦикла   
	КонецЕсли;
	
			
	Таб.АвтоМасштаб=Истина;
	Таб.Защита = Ложь;
	Таб.ПолеСверху=7;
	Таб.ПолеСнизу=7;		
	Таб.ПолеСлева=7;				
	Таб.ПолеСправа=7;						
	Таб.ТолькоПросмотр = Истина;
	Таб.ОтображатьСетку = Ложь;
	Таб.ОтображатьЗаголовки = Ложь;
		
КонецПроцедуры

 

4

Скачать файлы

Наименование Файл Версия Размер
Печать ценников Весового товара 1С: РОЗНИЦА 2.2:
.epf 16,44Kb
01.09.19
2
.epf 16,44Kb 2 Скачать

Специальные предложения

Избранное Подписка Сортировка: Древо
В этой теме еще нет сообщений.
Оставьте свое сообщение

См. также

Рекомендательный сервис на основе коллаборативной фильтрации на 1С. Расширение формы подбора для УТ 11.4 34

Инструменты и обработки Программист Расширение (cfe) v8 ERP2 УТ11 КА2 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m) Оптовая торговля Розничная торговля Практика программирования Математика и алгоритмы

В данной разработке реализован механизм рекомендаций товаров по принципу схожести товаров в корзине на основе алгоритма Item-to-Item от Amazon. Разобран алгоритм с демо базой и сделано расширение для УТ11.4 которое добавляет в форму подбора таблицу рекомендаций. Протестировано на 8.3.13.1865 на Управление торговлей, редакция 11 (11.4.8.63)

3 стартмани

25.09.2019    3918    8    informa1555    24       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Выгрузка номенклатуры в социальную сеть Вконтакте 34

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Оптовая торговля Розничная торговля Абонемент ($m) WEB

Обработка для быстрой и легкой выгрузки товаров Вконтакт. Так просто еще не было)))

2 стартмани

14.08.2019    4958    16    kalyuzhny    25       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

[Расширение] для подключения мобильного устройства к УТ11.4/ КА 2/ERP 2 для работы с ордерным складом на базе Simple WMS. Для автоматизации склада нужен только телефон 24

Инструменты и обработки Программист Пользователь Расширение (cfe) v8 ERP2 УТ11 КА2 УУ Оптовая торговля Розничная торговля Учет ТМЦ Абонемент ($m) Сканер штрих-кода Терминал сбора данных Мобильная разработка Управление торговлей

Представляю готовое решение для работы с ордерами и проведения инвентаризаций в виде расширения на базе конструктора Simple WMS. Не требует доработки конфигурации, подключается как обычное расширение. Работать может с обычного телефона на Андроид либо с ТСД либо через RDP. Расширение содержит справочники, поэтому режим совместимости конфигурации должен быть не меньше 8.3.11. Расширение написано для конфигурации Управление торговлей 11.4.7 и тестировалось на Комплексная автоматизация 2.4.7.151.

5 стартмани

27.05.2019    5691    26    informa1555    20       

Декларации по формам 11 и 12 алкогольной продукции, интеграция с ПО Декларант-Алко 20

Отчеты и формы Бухгалтер Архив с данными v8 Розничная и сетевая торговля (FMCG) Россия БУ Розничная торговля Абонемент ($m) Регламентированная отчетность Внешние источники данных

Конфигурация на обычных формах, платформа 1С 8.2.19.130 и выше, с помощью которой можно сформировать Декларации по формам 11 и 12 алкогольной продукции, гибрид/интеграция с ПО Декларант-Алко версии 4.31.05 и выше.

1 стартмани

25.03.2019    3911    8    independ    6       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Онлайн-курс «Практические аспекты внедрения регламентированного учета и расчета себестоимости в 1С:ERP на крупных промышленных предприятиях» с 17 февраля по 13 марта 2020 года. Промо

Курс рассчитан для подготовки экспертов по регламентированному учету и учету затрат для внедрения на крупных промышленных предприятиях с «исторически сложившимся» учетом

9000 рублей

Конструктор мобильного клиента Simple WMS Client: способ создать полноценный ТСД без мобильной разработки. Теперь новая версия - Simple UI (обновлено 14.11.2019) 186

Инструменты и обработки Программист Архив с данными v8 v8::Mobile БУ УУ Android Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Абонемент ($m) Инструментарий разработчика Сканер штрих-кода Терминал сбора данных Мобильная разработка

Simple WMS Client – это визуальный конструктор мобильного клиента для терминала сбора данных(ТСД) или обычного телефона на Android. Приложение работает в онлайн режиме через интернет или WI-FI, постоянно общаясь с базой посредством http-запросов (вариант для 1С-клиента общается с 1С напрямую как обычный клиент). Можно создавать любые конфигурации мобильного клиента с помощью конструктора и обработчиков на языке 1С (НЕ мобильная платформа). Вся логика приложения и интеграции содержится в обработчиках на стороне 1С. Это очень простой способ создать и развернуть клиентскую часть для WMS системы или для любой другой конфигурации 1С (УТ, УПП, ERP, самописной) с минимумом программирования. Например, можно добавить в учетную систему адресное хранение, учет оборудования и любые другие задачи. Приложение умеет работать не только со штрих-кодами, но и с распознаванием голоса от Google. Это бесплатная и открытая система, не требующая обучения, с возможностью быстро получить результат.

5 стартмани

09.01.2019    27684    231    informa1555    198       

ККТ Атол: настраиваем работу по новому порядку. 54ФЗ, ФФД 1.05, НДС 20%. + Работа ККТ по сети или как работать c ККТ из терминального сервера RDP + Работа в LINUX 23

Инструменты и обработки Системный администратор Архив с данными v8 УТ10 УПП1 ОС Кассовые операции Розничная торговля Абонемент ($m) ККМ

Настройка ККТ АТОЛ для работы по сети. Обработка обслуживания ККТ для конфигураций на обычных формах. Тестировал на УПП 1.3.106.2, УТ10.3.47.3. Платформа 8.3.10.2753

1 стартмани

14.12.2018    37782    54    Johny_v    42       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

Анализ активности продавцов для УТ 11 3

Отчеты и формы Бизнес-аналитик Пользователь Руководитель проекта Внешний отчет (ert,erf) v8 v8::ОУ v8::СКД УТ11 Розничная и сетевая торговля (FMCG) Россия УУ Розничная торговля Абонемент ($m) Управленческие

Отчет позволяет проанализировать качество работы продавцов, а также сравнить показатели розничных точек продаж (магазинов).

5 стартмани

26.11.2018    4391    Zalipaka    0       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Загрузка чека онлайн-касс (загрузка товаров из чека) 39

Инструменты и обработки Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v8 1cv8.cf Кассовые операции Розничная торговля Абонемент ($m) Внешние источники данных WEB

Обработка-пример, позволяет любому и из любой конфигурации загрузить информацию о товарах из чека(и не только) с сервера ФНС proverkacheka.nalog.ru

2 стартмани

08.10.2018    10254    26    echo77    33       

Кое-что простое о сложных штрих-кодах 33

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf УУ Розничная торговля Абонемент ($m) Сканер штрих-кода Бухгалтерский учет

На просторах и-нета часто встречаю публикации, в которых авторы с энтузиазмом рассказывают о том, как в штрих-код внести информацию о нескольких сущностях: например, как сделать, чтобы при сканировании одного штрих-кода на ярлыке товара, 1С определяла что это за товар, его качество и приходную накладную по которой этот товар поступил. Увы, но делается это "в лоб". Я предлагаю более разумный способ. Он очевиден - так что не претендую на лавры первооткрывателя.

1 стартмани

28.09.2018    9114    6    torch    15       

INFOSTART MEETUP Kazan. 13 марта 2020 г. Промо

Инфостарт продолжает путешествие по России. Следующая остановка - Казань. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Ждем всех: докладчиков и участников! Стоимость участия - 5 500 рублей. Цена действительна до 30.01.2020

5 500

Расширение "Интерфейс Плюс" 45

Отчеты и формы Бухгалтер Пользователь Расширение (cfe) v8 v8::ОУ Розница УТ11 Россия УУ Розничная торговля Абонемент ($m) Рабочее место

Расширение для 1С:Розница 2.2 и 1С:Управление Торговлей 11, которое позволит повысить удобство работы!

3 стартмани

22.09.2018    12918    107    RocKeR_13    86       

Помощник корректировки остатков ЕГАИС в небольшом магазине. Розница 2.2 12

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 Розница Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия УУ Розничная торговля Абонемент ($m) Обработка документов

Данная обработка упрощает корректировку остатков алкогольной продукции небольшого магазина, где предполагается передача всей продукции в торговый зал сразу после приемки.

5 стартмани

08.09.2018    18826    79    asdfgcom    46       

Базовый курс по разработке мобильных 1C-приложений для Android-устройств. Третий поток. Онлайн-интенсив с 11 февраля по 05 марта 2020 г. Промо

Данный онлайн-курс предусматривает изучение базовых принципов создания приложений для операционной системы Android, работающих на мобильной платформе “1С:Предприятие”. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие” при разработке прикладных решений для “обычных” компьютеров, но пока ещё не занимался разработкой 1С-приложений, предназначенных для работы на мобильных устройствах.

7500 рублей

Загрузка файлов/картинок/изображений/фото номенклатуры PRO 25

Инструменты и обработки Программист Пользователь Внешняя обработка (ert,epf) v8 v8::УФ Розница УНФ УТ11 Россия Оптовая торговля Розничная торговля Абонемент ($m) Управленческий учет (прочее)

Пожалуй, самая многофункциональная обработка для пополнения каталога. Сопоставление изображений с номенклатурой по артикулу, коду и подстроке; обновление/замена, удаление фото; установка основного изображения по расширению или по любой части наименования файла. Информация о файлах и результаты сопоставления с номенклатурой отображается в таблице. Для каждого изображения есть возможность предпросмотра. Процесс загрузки картинок отображается через прогресс-бар.

1 стартмани

03.08.2018    11697    73    zannv    29       

Печать НД с PDF417 x64 31

Инструменты и обработки Программист Бухгалтер Пользователь Расширение (cfe) v8 БП3.0 ЗУП3.x Россия НУ Абонемент ($m) Ценники

Переходник для использования 32-битного COM-объекта "Печать НД с PDF417" с 64-битным тонким клиентом.

1 стартмани

18.07.2018    25544    222    VGHOST    52       

Перенос данных УПП 1.3 => ERP 2 (ЕРП) / УТ 11 / КА 2.х (обработка переноса документов, остатков и справочников из "1С:Управление производственным предприятием, ред. 1.3" в ERP / УТ 11 / КА 2). Обновлен до УПП 1.3.130.х, КА 2.4.11.х и ERP 2.4.11.х! Промо

Обработка позволяет переносить из УПП 1.3 в ERP 2 документы за выбранный период и остатки. Типовая обработка от фирмы 1С документы не переносит. Также исправлены ошибки типовой обработки. При выходе новых релизов обновление высылается бесплатно в течение года. Разработка будет полезна фирмам-франчайзи, которые периодически выполняют такой перенос данных для заказчиков. Вы можете один раз приобрести обработку переноса, и потом бесплатно получать обновления при выходе новых релизов конфигураций 1С.

29700 руб.

Виртуальная дисконтная карта на OneScript 19

Инструменты и обработки Программист Конфигурация (md, cf) v8 УУ Оптовая торговля Розничная торговля Абонемент ($m) OneScript

В статье рассмотрены возможности http-сервисов OneScript для создания бизнес-приложений, на примере демонстрационной конфигурации, реализующей функционал виртуальной дисконтной карты.

1 стартмани

17.07.2018    7241    4    blackhole321    6       

Корректировка остатков ЕГАИС 18

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 Розница Россия УУ Розничная торговля Абонемент ($m) Обработка документов

Обработка по типу "Помощник корректировки остатков ЕГАИС", которую убрали в 1С Розница 2.2.8.

1 стартмани

17.06.2018    17104    265    empafe    53       

22 января состоится вебинар "Использование технологии блокчейн в 1С" Промо

На вебинаре вы узнаете как использовать современную технологию блокчейн при проектировании и создании учетных систем, почему эту технологию следует рассматривать как одну из базовых. Ведущий Михаил Калимулин поделится своими знаниями основ технологии и опытом внедрения.

990 рублей

ЕГАИС 3 Контролёр для 1С:Розница 7

Инструменты и обработки Системный администратор Пользователь Внешняя обработка (ert,epf) v8 Розница Розничная и сетевая торговля (FMCG) Россия УУ Android Розничная торговля Абонемент ($m) Терминал сбора данных

Оградите себя от рисков отзыва лицензии на торговлю алкоголем, штрафов и блокировок в ЕГАИС. Проверяйте поступающую алкогольную продукцию помарочно на соответствие ТТН ЕГАИС v3 перед тем, как подтвердить получение и принять её на баланс в ЕГАИС. С 01.07.2018 начинается переход ЕГАИС на помарочный учет алкогольной продукции на всех стадиях товародвижения, начиная от производства или ввоза на территорию России, до реализации в розничной торговле, т.н. "ЕГАИС 3.0". В типовой Рознице уже появилась обработка для контроля поступивших акцизных марок на ПК. Предлагаю ознакомиться с мобильным решением. Контроль производится в Android приложении на ТСД или на обычном смартфоне.

1 стартмани

13.06.2018    12124    16    kuld    30       

Пробитие чеков через ККМ в офисе (для курьеров) 12

Инструменты и обработки Пользователь Расширение (cfe) v8 v8::ОУ Розница УТ11 Россия БУ Кассовые операции Розничная торговля Абонемент ($m) ККМ Фискальный регистратор

Предлагается интеграция 1С с ККТ СтарРус. Поддерживается одновременная работа с разных рабочих мест. ККТ СтарРус работает как сервер, и принимает команды через API по http-протоколу, что позволяет пробивать чеки через центральную базу 1С для интернет-магазина и для курьеров.

1 стартмани

07.06.2018    21330    27    Kutuzov    12       

Перенос данных УТ 10.3 => УТ 11 / КА 2 / ERP 2 (ЕРП 2) (документы, остатки и справочная информация из "1С:Управление торговлей, ред. 10.3" в УТ 11 / КА 2 / ERP 2). Обновлен до УТ 10.3.56.х, УТ 11.4.10.х, КА 2.4.10.х и ERP 2.4.10.х! Промо

Уже более 100 компаний приобрели перенос и выполнили переход на УТ 11 / КА 2 / ERP 2 с помощью нашей разработки! Обработка перехода с УТ 10.3 на УТ 11 / КА 2 / ERP 2 позволяет перенести не только остатки на указанную дату (как типовой перенос), но и все возможные документы за выбранный период. При выходе новых релизов этих программ оперативно выпускаем обновление обработки. Предоставляем техническую поддержку. Можем сделать бесплатный тестовый перенос!

29700 руб.

Корректировка остатков ЕГАИС для 1С:Розница/УТ 10.3 - альтернативный вариант 63

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 Розница Розничная и сетевая торговля (FMCG) БУ Розничная торговля Учет ТМЦ Абонемент ($m) Обработка документов

Обработка корректировки остатков ЕГАИС для 1С Розница версии 2.2.7/2.2.8/2.2.9/2.2.10/2.2.11/УТ 10.3.47.ХХХ-48.XXX-49.XXX-50.XXX раздельно по маркируемому/немаркируемому алкоголю + создание документов постановки/списания по пересортице.

1 стартмани

02.06.2018    22259    329    independ    242       

Yep Cart. Пишем интернет-магазин на http-сервисах OneScript 45

Статья Программист Конфигурация (md, cf) v8 УУ Оптовая торговля Розничная торговля Абонемент ($m) OneScript

В статье описана демонстрационная конфигурация, реализующая простейший интернет магазин на http-сервисах OneScript, интегрированный с 1С:Предприятие.

1 стартмани

16.04.2018    11746    15    blackhole321    33