Подключаем внешнюю печатную форму в режиме отладчика

Публикация № 1214650

Разработка - Печать - Универсальные печатные формы

Всем привет. Долго мучался с подключением внешних печатных форм (далее ВПФ), а именно их отладкой, т.е. при подключении ВПФ, зачастую она не открывается сразу или не выводится на печать, восстанавливать без отладчика сложно и долго, а поставив точку останова, она попросту не подключается к отладчику, поэтому здесь я покажу, что сделал я.

Конфигурация у меня УТ 11.4 + CRM, короче УТ11.4, я сделал выгрузил рабочую базу через конфигуратор в файл dt. Затем создал папку тестовая база, открыл программу и создал новую базу без конфигурации, каталогом разумеется указал, выше созданную папку, далее открыл новую базу в режиме конфигуратора и загрузил тот dt файл который мы выгрузили, кстати, все это я сделал на учебной (демо) платформе.

Но этот метод можно использовать и на серверной базе.

 База у нас находится нп поддержке 1с, т.е. она типовая, следовательно изменять конфигурацию мы не будем, но для решения моего метода, нужно внести изменения в код конфигурации и что же блин делать, а вот что создаем расширение: нажимаем Конфигурация-Расширения конфигурации, далее нажимаем на беленький плюсик на зеленом фоне (добавить) в открывшемся окне пишем как будем называть свое расширение у меня VID назначение оставляем адаптация.

После этого у нас помимо окна конфигурации появится и окно с нашим расширением, но оно пустое, если конечно у Вас уже есть расширение, то создавать не нужно пропустите этот шаг.

Далее ищем во вкладке конфигурации Общая - общие модули и ищем модуль под названием: ДополнительныеОтчетыИОбработки, нажимаем правой кнопкой на этот модуль и добавляем в наше расширение:

После этого у нас откроется пустое окно, а именно это модуль который мы добавили, но только он в расширении и он пустой, поэтому теперь ищем в том же модуле конфигурации функцию ПодключитьВнешнююОбработку и процедуру ПриПолученииРегистрационныхДанных, над функцией добавляем атрибут Вместо, а над процедурой После, а также переименовываем процедуру и функцию, чтобы они не дублировались с основной конфигурации, я добавил свой идентификатор и сокращение расширение, т.е. VID_Расш

 Далее открываем данную функцию и меняем часть кода на этот, а оригинальный код комментируем:

ИмяОбработки = Менеджер.Создать ("C:\ВашаФорма.epf", Ложь);
ИмяОбработки = "ВашаФорма"

 Скопировать путь фашей формы можно следующим способом, находите вашу форму и удерживая клавишу Shift нажимаем ПКМ (правая кнопка мыши - это та которую вы будете видит справа от левой)))), и у вас появится там надпись "копировать как путь", ее и нажимаете, путь у Вас копируется в буфер обмена компьютера, а вам остается только вставить в код, опять же правой кнопкой мыши или нажимая Ctrl + V. 

Далее открываете процедуру и также вносите изменения в код:

ВнешнийОбъект = Менеджер.Создать ("С:\ВашаФорма.epf", Ложь);

После этого нужно изменить режим совместимости на Вашем расширении, некоторые говорят, что нужно менять и на расширении и на самой конфигурации, но у меня все работает и без изменения режима совместимости на конфигурации, для изменения режима правой кнопкой мыши нажмите на название вашего расширения у меня это VID, в самом вверху окна конфигурации и далее свойства, справа у Вас откроется вкладка со свойствами расширения: в самом низу измените режим совместимости на "не использовать", сомтрите рисунок, также второй рисунок показывает то, что в самой конфигурации у меня по прежнему остался режим совместимости.

На этом все работы по настройки тестовой конфигурации закончены, и пускай она у Вас будет только для работы с внешними отчетами и обработками, это очень удобно - не нужно постоянно переприсоединять внешние обработки, а все из-за того, что программа напрямую считывает нашу обработку с указанного на компьютере места, поэтому при нажатии на кнопку сохранить, можно сразу смотреть что изменилось, а что нет! 

Я установил точку останова с помощью клавиши F9, также можно клацнуть мышкой по серенькой полоске в модуле два раза она тоже появиться, установил я ее на функцию СведенияОВнешнейОбработке, затем открыл программу 1С в режиме отладчика, Нажал: НСИ и администрирование - Печатные формы, отчеты и обработки - -Дополнительные отчеты и обработки, затем нажал на кнопку добавить и обновить из файла, указываем именно ту обработку к которой указывали путь в модуле!

Разумеется из-за того, что точку мы установили на функцию СведенияОВнешнейОбработке, то при добавлении обработки, нас сразу перенесло в режим конфигуратора и появилась та нужная нам белая стрелка на красном кружке.

Не обессудьте, хорошего всем дня и главное не болеть! 

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. nomad_irk 48 23.03.20 16:14 Сейчас в теме
(0) Т.е. добавить форму в обработке с полем выбора нужного вида объекта и кнопкой, выполняющим формирование печатной формы, не получилось?
Sedaiko; Бэнни; +2 Ответить
2. VID1234 40 23.03.20 16:15 Сейчас в теме
3. VmvLer 23.03.20 16:37 Сейчас в теме
очередной костыль и по коду ясно, что только в толстом клиенте, почему только в толстом - мне лень его запускать, да и забыл когда использовал.

РежимОтладки и увеличенный пулл портов отладки, иногда F11 - решают задачу отладки на 100%.

Если есть желание извращаться с внешним файлом
- в любом клиенте современной БСП
- с внешними отчетами с комами и прочей щняжкой
-...
, то я прикрутил в расширение код попроще

просто бросаем этот код в расширяемый модуль(указано в комментах),
никаких полей и шамантва больше не нужно

и доп.отчет (обработку) можно отладить из файла, указав имя файла в поле
"комментарий" этой обработки. Первый вариант можно записать как болванку.


#Область Расш1_ОтладкаВнешнихОбъектовБСП_ОбщийМодуль_ДополнительныеОтчетыИОбработки

&Вместо("ПодключитьВнешнююОбработку")
Функция Расш1ПодключитьВнешнююОбработку(Ссылка)
	
	// Метод основной конфигурации выполнит возврат имени объекта подключенного из справочника внешних обчетов и обработок 
	Результат = ПродолжитьВызов(Ссылка);  // Возврат ИмяОбработки; 
	
	// Расширяем метод основной конфигурации если у внешнего объекта включен режим отладки и указано имя файла объекта отладки в поле "Комментарий".
	ОбъектОтладкиФайлПолноеИмя = Расш1ПолучитьПолноеИмяФайлаВнешнегоОбъектаОтладки(Ссылка);
	Если НЕ ПустаяСтрока(ОбъектОтладкиФайлПолноеИмя) Тогда
		ОбъектОтладки = ПолучитьВнешнийОбъектОтладки(Ссылка, ОбъектОтладкиФайлПолноеИмя); // Получаем внешний объект отладки по имени файла
		Результат = ОбъектОтладки.Метаданные().Имя; // Переопределяем результат который возвращает метод основной конфигурации 
	КонецЕсли;
	
	Возврат Результат;
	
КонецФункции

&Вместо("ПриПолученииРегистрационныхДанных")
Процедура Расш1ПриПолученииРегистрационныхДанных(Объект, РегистрационныеДанные, ПараметрыРегистрации, РезультатРегистрации)
	
	ПродолжитьВызов(Объект, РегистрационныеДанные, ПараметрыРегистрации, РезультатРегистрации);
	
	// Расширяем метод основной конфигурации если у внешнего объекта включен режим отладки и указано имя файла объекта отладки в поле "Комментарий".
	ОбъектОтладкиФайлПолноеИмя = Расш1ПолучитьПолноеИмяФайлаВнешнегоОбъектаОтладки(Объект.Ссылка);
	Если НЕ ПустаяСтрока(ОбъектОтладкиФайлПолноеИмя) Тогда
		
		ВнешнийОбъект = ПолучитьВнешнийОбъектОтладки(Объект.Ссылка, ОбъектОтладкиФайлПолноеИмя);  // Получаем внешний объект отладки по имени файла
		ВнешнийОбъектМетаданные = ВнешнийОбъект.Метаданные();
		
		СведенияОВнешнейОбработке = ВнешнийОбъект.СведенияОВнешнейОбработке();
		ОбщегоНазначенияКлиентСервер.ДополнитьСтруктуру(РегистрационныеДанные, СведенияОВнешнейОбработке, Истина);
		
		// ≪✔▼ СКОПИРОВАННЫЙ БЛОК КОДА из окончания метода основной конфигурации ▼≫
		Если РегистрационныеДанные.Наименование = Неопределено ИЛИ РегистрационныеДанные.Информация = Неопределено Тогда
			Если РегистрационныеДанные.Наименование = Неопределено Тогда
				РегистрационныеДанные.Наименование = ВнешнийОбъектМетаданные.Представление();
			КонецЕсли;
			Если РегистрационныеДанные.Информация = Неопределено Тогда
				РегистрационныеДанные.Информация = ВнешнийОбъектМетаданные.Комментарий;
			КонецЕсли;
		КонецЕсли;
		
		Если ТипЗнч(РегистрационныеДанные.Вид) <> Тип("ПеречислениеСсылка.ВидыДополнительныхОтчетовИОбработок") Тогда
			РегистрационныеДанные.Вид = Перечисления.ВидыДополнительныхОтчетовИОбработок[РегистрационныеДанные.Вид];
		КонецЕсли;
		
		РегистрационныеДанные.Вставить("ХранилищеВариантов");
		Если РегистрационныеДанные.Вид = Перечисления.ВидыДополнительныхОтчетовИОбработок.ДополнительныйОтчет
			Или РегистрационныеДанные.Вид = Перечисления.ВидыДополнительныхОтчетовИОбработок.Отчет Тогда
			Если ВнешнийОбъектМетаданные.ХранилищеВариантов <> Неопределено Тогда
				РегистрационныеДанные.ХранилищеВариантов = ВнешнийОбъектМетаданные.ХранилищеВариантов.Имя;
			КонецЕсли;
		КонецЕсли;
		
		РегистрационныеДанные.Команды.Колонки.Добавить("ВариантЗапуска");
		
		Для Каждого КомандаОписание Из РегистрационныеДанные.Команды Цикл
			КомандаОписание.ВариантЗапуска = Перечисления.СпособыВызоваДополнительныхОбработок[КомандаОписание.Использование];
		КонецЦикла;
		
		#Если ТолстыйКлиентОбычноеПриложение Тогда
			РезультатРегистрации.ИмяОбъекта = ВнешнийОбъектМетаданные.Имя;
		#КонецЕсли
		// ≪✔▲ СКОПИРОВАННЫЙ БЛОК КОДА из окончания метода основной конфигурации ▲≫
		
	КонецЕсли;
	
КонецПроцедуры

Функция Расш1ПолучитьПолноеИмяФайлаВнешнегоОбъектаОтладки(Ссылка)

	ОбъектОтладкиФайлПолноеИмя = "";
	
	Если Ссылка.Публикация = Перечисления.ВариантыПубликацииДополнительныхОтчетовИОбработок.РежимОтладки Тогда
		ТекстОшибки = "";
		ЗаголовокОшибки = "
		|Для внешнего объекта вида " + """" + Ссылка.Вид + """" + " с именем " + """" + Ссылка.Наименование + """
		|включен режим отладки, что означает отладку объекта из файла. Причем, путь к файлу 
		|должен быть доступен на сервере и указан в поле ""Комментарий"" внешнего объекта.";
		
		ОбъектОтладкиФайлПолноеИмя = СокрЛП(Ссылка.Комментарий);
		Если ПустаяСтрока(ОбъектОтладкиФайлПолноеИмя) Тогда
			ТекстОшибки = "
			|
			|Обратитесь к разработчику!";
		Иначе	
			ПроверяемыйФайл = Новый Файл(ОбъектОтладкиФайлПолноеИмя);
			Если НЕ ПроверяемыйФайл.Существует() Тогда
				ТекстОшибки = "
				|
				|Файл не существует по указанному пути: """ +ОбъектОтладкиФайлПолноеИмя+ """ 
				|
				|Если после записи объекта ошибка возникнет вновь, то обратитесь к разработчику!";
			КонецЕсли;
		КонецЕсли;
		
		Если НЕ ПустаяСтрока(ТекстОшибки) Тогда
			ВызватьИсключение (ЗаголовокОшибки + ТекстОшибки); 
		КонецЕсли;
		
	КонецЕсли;	

	Возврат  ОбъектОтладкиФайлПолноеИмя;
	
КонецФункции 

Функция ПолучитьВнешнийОбъектОтладки(Ссылка, ОбъектОтладкиФайлПолноеИмя)
	
	// Получение менеджера внешнего объекта
	Вид = Ссылка.Вид; 
	Если Вид = Перечисления.ВидыДополнительныхОтчетовИОбработок.Отчет ИЛИ Вид = Перечисления.ВидыДополнительныхОтчетовИОбработок.ДополнительныйОтчет Тогда
		Менеджер = ВнешниеОтчеты;
	Иначе
		Менеджер = ВнешниеОбработки;
	КонецЕсли;
	
	// Создание внешнего объекта по полному имени файла
	ОбъектОписанияЗащиты = Новый ОписаниеЗащитыОтОпасныхДействий;
	ОбъектОписанияЗащиты.ПредупреждатьОбОпасныхДействиях = Ложь; // Отключает предупреждения защиты незавимо от настроек пользователя и информациооной базы
	ОбъектОтладки = Менеджер.Создать(ОбъектОтладкиФайлПолноеИмя, Ложь, ОбъектОписанияЗащиты); // БезопасныйРежим = Ложь, ОбъектОписанияЗащиты
	
	Возврат ОбъектОтладки;
	
КонецФункции

#КонецОбласти
Показать



Насчет код попроще я погарячился, главное когда мне надо отладить внешний отчет/ обработку я просто пишу имя файла(доступное на сервере, например \\....) в комментарий элемента справочника внешних отчетов и в этом же элементе жму кнопку Отладка - всё.
По завершении отладки стираю путь, отжимаю кнопку и заливаю новую версию в элемент.

Этот код я тут кидал ранее и то, что автор пришел к той же методике не удивительно - другие пути более сложны.
Правда, мне лень разбираться почему почему у автора толстый клиент и много воды.
Dimasik2007; +1 Ответить
6. VID1234 40 23.03.20 17:15 Сейчас в теме
4. nomad_irk 48 23.03.20 17:00 Сейчас в теме
Просто оставлю это здесь.......
Прикрепленные файлы:
ВПФ_БолванкаСВозможностьюОтладки.epf
Sedaiko; work.sable; adeich; Il; wowik; +5 Ответить
5. VID1234 40 23.03.20 17:15 Сейчас в теме
7. davdykin 22 23.03.20 17:25 Сейчас в теме
я дела практически такое же расширение, но я перехватил добавление файла печатной формы во внешние доработки, и сохранял его путь в коментарий, а потом создавал обработку из этого пути, таким образом не меняя расширение можно отлаживать любое количество печатных форм.
8. VID1234 40 23.03.20 17:29 Сейчас в теме
9. v_id 98 23.03.20 20:27 Сейчас в теме
10. VID1234 40 24.03.20 14:09 Сейчас в теме
(9) Спасибо. Я только встретил такую фишку, попробую.
11. leosoft 145 24.03.20 14:23 Сейчас в теме
12. v_id 98 24.03.20 15:20 Сейчас в теме
13. leosoft 145 24.03.20 15:42 Сейчас в теме
(12) Понятно, про эти инструменты я знаю, спасибо.
Оставьте свое сообщение

См. также

Макеты печатных форм в руках пользователей (обычные формы)

Статья Программист Нет файла v8 Россия Бесплатно (free) Практика программирования Универсальные печатные формы

Как частично избавить себя от низкопрофильного труда по правке печатных форм. Для конфигураций на основе БСП, конечно, не актуально, но для нетиповых вполне. Ну и как в помощь начинающим. У меня реализовано для печати различных "согласие на обработку персональных данных","согласие на медицинские вмешательства", различных анкет. Удобно для печатных форм, которые часто по тем или иным причинам меняются. Чтоб не дергать программиста, пусть пользователи рисуют макеты самостоятельно.

01.11.2018    6125    fromlion    3       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Подход к организации печати одного макета документа из обычной и управляемой форм документа (интерфейс Такси)

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Универсальные печатные формы Печатные формы документов Математика и алгоритмы

В статье описывается подход к реализации печати одного макета из управляемой и обычной формы документа. Описанная методика близка к преподаваемой в учебных центрах 1С.

10.10.2013    37032    RailMen    9       

Форма МП-сп статистика Росстат

Инструменты и обработки Бухгалтер Внешний отчет (ert,erf) v8 БП2.0 Бесплатно (free) Универсальные печатные формы Загрузка и выгрузка в Excel Статистические

Регламентная форма статистики МП-сп для Росстата под 1С:Бухгалтерия 1.6.23-30 и Бухгалтерия 2.0.18-19 на платформах 8.1 и 8.2. Заполняет, выводит печатную форму. Возможности отправки в электронном виде (XML-файл для Такском Спринтер) пока нет.

31.03.2011    46561    261    milov.aleksey    5       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Инвентаризационная ведомость с выбором типа цены и по группам

Отчеты и формы no Внешняя обработка (ert,epf) v8 УТ10 УУ Розничная торговля Учет ТМЦ Бесплатно (free) Универсальные печатные формы Управленческие

Дает возможность проведения инвентаризации в любых типах цен, в частности - по розничной. Выводит по группам и с колонкой отклонений.

18.01.2011    9245    239    leska    15       

Формирование списка сотрудников на оформление банковских карт для Сбербанка

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 ЗУП2.5 Россия Банковские операции Зарплата Бесплатно (free) Обработка документов Универсальные печатные формы Обмен с банком

Внешняя обработка для 1С:8.1 ЗУП 2.5. Формирует список сотрудников (только работающих), на которых необходимо сделать банковские карты Сбербанка. Формирование списка возможно с отбором по периоду даты приема сотрудников.

10.11.2010    13828    124    pavel_pss    3       

Онлайн-курс «Практические аспекты внедрения регламентированного учета и расчета себестоимости в 1С:ERP на крупных промышленных предприятиях» с 20 апреля по 15 мая 2020 года. Промо

Курс рассчитан для подготовки экспертов по регламентированному учету и учету затрат для внедрения на крупных промышленных предприятиях с «исторически сложившимся» учетом

9000 рублей

Реестр документов контрагентов со свойствами и категориями (УПП,УТ,КА 8.1/8.2)

Отчеты и формы no Внешняя обработка (ert,epf) v8 КА1 УТ10 УПП1 Бесплатно (free) Универсальные печатные формы Управленческие

Простенький отчет на СКД с не очень простенькой настройкой для отображения реестра документов контрагентов с доп.свойствами и категориями.

12.08.2010    23723    453    anig99    10       

Печать договора с контрагентом из 1С в MS Word (для 1С: Управление торговлей)

Отчеты и формы no Внешняя обработка (ert,epf) v8 УТ10 Windows Бесплатно (free) Универсальные печатные формы

Печать договора с контрагентом. Внешняя обработка формирует договор с контрагентом и выгружает его в MS Word. Пункты договора под свои можете отредактировать через макет. На моем предприятии - это договор на поставку инертных материалов.

29.03.2010    31196    1975    SvetaTsp    27       

Онлайн-интенсив "1C:Предприятие для программистов: Бухгалтерские задачи" с 22 июня по 8 июля 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, которые предназначены для решения задач бухгалтерского учета. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей прикладного решения “1С:Бухгалтерия” и прочих прикладных решений, в которых реализованы соответствующие механизмы для автоматизации бухгалтерских задач.

4900 рублей

Печать договора с контрагентом из 1С в MS Word (для 1С: Бухгалтерия предприятия)

Отчеты и формы no Внешняя обработка (ert,epf) v8 БП2.0 Windows Бесплатно (free) Универсальные печатные формы

Печать договора с контрагентом. Внешняя обработка формирует договор с контрагентом и выгружает его в MS Word. Пункты договора под свои можете отредактировать через макет. На моем предприятии - это договор на поставку инертных материалов.

11.03.2010    14544    669    SvetaTsp    23       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

АНКЕТА НА ВИЗУ ФРАНЦИИ

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Управление персоналом (HRM) Бесплатно (free) Универсальные печатные формы

Отчет позволяет на основании хранимых в базе анкетных данных сотрудников сформировать анкету на визу Франции в электронном виде. Транслитерация производится по ГОСТ 7.79-2000 (ИСО 9-95) Межгосударственный стандарт «Правила транслитерации кирилловского письма латинским алфавитом»

06.01.2010    7046    57    Svetlachok    4       

Формирование договора в Ворде из справочника Сотрудники 1С8 (ЗУП или УПП)

Отчеты и формы no Внешняя обработка (ert,epf) v8 ЗУП2.5 УПП1 Windows Управление персоналом (HRM) Бесплатно (free) Универсальные печатные формы

В конфигурации УПП в справочник Сотрудники добавлена кнопка, по которой запускается код, позволяющий вызвать шаблон трудового договора с принимаемым на работу сотрудником, заполнить его данными этого сотрудника (из справочника Сотрудники) и сохранить его в Ворде с номером трудового договора, соответствующим номеру трудового договора в справочнике Сотрудники. Обработка представляет собой модификацию этого кода, позволяющего запускать его из внешней обработки в любой информационной базе УПП или ЗУП. На базе этой обработки можно делать другие обработки, формирующие документы в Ворде по информации из 1С8 любой конфигурации.

19.06.2009    7718    363    hoholist    12       

Базовый курс для начинающих 1С-программистов. Онлайн-интенсив со 2 июня по 2 июля 2020 г. Промо

Данный онлайн-курс является начальной ступенью по изучению базовых принципов программирования в системе “1С:Предприятие” и предназначен для обучения 1С-программированию “с нуля”.

4500-9500 рублей

Обработка печати списка номенклатуры со свойствами, ценой и штрихкодами

Отчеты и формы Бухгалтер Пользователь Внешняя обработка (ert,epf) v8 УПП1 Бесплатно (free) Универсальные печатные формы

Простая обработка печати справочника номенклатуры со свойствами, ценой и штрихкодами, нужна для контроля заполнения списка реквизитов на этапе внедрения.

03.04.2009    9302    199    angeliccare    4       

Базовый курс по обмену данными в системе 1С:Предприятие. Онлайн-интенсив с 12 по 28 мая 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, обеспечивающих обмен данными между различными прикладными 1С-решениями и взаимодействие с другими информационными системами. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”.

5500 рублей

Формирование трудового договора на основании шаблона MS Word

Инструменты и обработки no Внешняя обработка (ert,epf) v8 ЗУП2.5 Россия Windows Управление персоналом (HRM) Бесплатно (free) Универсальные печатные формы Загрузка и выгрузка в Excel

Внешняя обработка для конфигурации "Зарплата и управление персоналом". Позволяет формировать трудовой договор на основании шаблона, подготовленного в MS Word.

19.12.2008    12012    1040    vovk_v    14       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Универсальная печатная форма

Инструменты и обработки Программист Бизнес-аналитик Внешняя обработка (ert,epf) v8 1cv8.cf Бесплатно (free) Универсальные печатные формы Инструментарий разработчика

Две универсальные внешние печатные формы для типовых конфигураций В одной нужные реквизиты отмечаем флажками. В другой настраиваем вывод построителем отчета.

31.08.2007    11103    143    ignor    12