Реестр прямых выплат ФСС в формате 1.7.6 вместо 1.7.7 для ЗУП и ЗГУ 3.1.14.394 и 3.1.16.133 (расширение)

Публикация № 1369669

Разработка - Печать - Регламентированная отчетность

Реестр ФСС 1.7.6 1.7.7 реестр пособий прямых выплат

После обновления зарплаты до релизов 3.1.14.394 или 3.1.16.133 возникли проблемы, что Реестр прямых выплат ФСС выгружался с неполными данными и не проходил проверку при отправке в ФСС. Т.к. реестры ПВСО формата 1.7.6 будут приниматься до отдельного уведомления, то вернул формирования файла в этом формате, до исправления разработчиками выгрузки в формате 1.7.7.

Публикация предназначена для тех, у кого при выгрузке в новом формате после обновления ЗГУ или ЗУП до 3.1.14.394 и 3.1.16.133 не отправляются реестры в ФСС, а до этого в старом формате принимались.

Тестировал на ЗУП 3.1.14.394 и 3.1.16.133,  3.1.14.433 и 3.1.17.94, 3.1.14.465 и 3.1.17.135.

Подключить Расширение (Администрирование - "Печатные формы и обработки"; "Расширения"; Кнопка "Добавить из файла"(если обновляете уже установленный отчет "Обновить из файла") - Выбираем файл; Снимаем v "Безопасный режим" -"Перезапустить").
Может возникать ошибка при работе под "толстым клиентом"(способ исправления запускать под "тонким клиентом")

Изменение от 02.03.2021: добавил обработку для релиза 3.1.14.433 и 3.1.17.94

Изменение от 07.04.2021: добавил обработку для релиза 3.1.14.465 и 3.1.17.135

Скачать файлы

Наименование Файл Версия Размер
Реестр прямых выплат ФСС формат 1.7.6 для ЗУП и ЗГУ 3.1.14.394 и 3.1.16.133 вместо 1.7.7(расширение):

.cfe 12,88Kb
155
.cfe 12,88Kb 155 Скачать
Реестр прямых выплат ФСС формат 1.7.6 вместо 1.7.7 для ЗУП и ЗГУ 3.1.14.433 и 3.1.17.94 (расширение)

.cfe 18,65Kb
74
.cfe 18,65Kb 74 Скачать
Реестр прямых выплат ФСС в формате 1.7.6 вместо 1.7.7 для ЗУП и ЗГУ 3.1.14.465 и 3.1.17.135 (расширение):

.cfe 24,04Kb
35
.cfe 24,04Kb 35 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. saski 27.01.21 14:52 Сейчас в теме
Было бы полезнее, если бы вы подсказали где и что изменить.
А так народ мучается, и не знает что делать?
3. user1173399 28.01.21 06:53 Сейчас в теме
(1) ТУТ описание изменений - надо обавить в расширение документ "РеестрСведенийНеобходимыхДляНазначенияИВыплатыПособий" модуль менеджера, и там заменить код, взяв из версии 14.369 (Вместо)
- Процедура ЗаполнитьСтрокуРеестра(ROW, СтруктураДанных)
- Функция СформироватьФайлРеестра(ВыборкаПоШапкеДокумента, ВыборкаСведенийДляРасчетаПособия)
- Функция ИдентификаторФСС(Реестр)
prestige; +1 Ответить
7. Kaval88 152 28.01.21 10:29 Сейчас в теме
2. rybusha 97 28.01.21 02:31 Сейчас в теме
Большое спасибо .Больничный отправился ,протокол положительный.
4. asuktty 28.01.21 08:14 Сейчас в теме
Спасибо. Очень выручили.
5. medexe 28.01.21 08:59 Сейчас в теме
Спасибо! Была ошибка 508, расширение помогло.
6. Kaval88 152 28.01.21 10:26 Сейчас в теме
https://forum.infostart.ru/forum68/topic255183/ здесь есть расширение бесплатно. Можно брать
CepeLLlka; DenisMedvedev; +2 Ответить
8. LORP 28.01.21 11:08 Сейчас в теме
Спасибо, расширение работает!
9. luser 89 11.02.21 13:07 Сейчас в теме
на 3.1.14.395 работает только со снятой галкой "Безопасный режим"
10. as7bs 196 16.02.21 15:30 Сейчас в теме
(9) да, в публикации это написано, в описании как подключить "... Снимаем v "Безопасный режим" -"Перезапустить""
11. ikorulev 20 26.02.21 15:44 Сейчас в теме
Спасибо тебе добрый человек, выгрузилось на зуп 3.1.17.60, галку снял
12. ikorulev 20 01.03.21 11:57 Сейчас в теме
После обновления до 3.1.17.94 перестало работать
13. luser 89 01.03.21 12:08 Сейчас в теме
После обновления до 3.1.14.433 перестало работать
14. as7bs 196 02.03.21 11:28 Сейчас в теме
(12)
(13)
Постараюсь вечером адаптировать для новых релизов.
15. as7bs 196 02.03.21 18:36 Сейчас в теме
(12)
(13)
(14)
добавил расширение для релиза 3.1.14.433, должно работать и на 3.1.17.94.
Разработчики изменили схему XDTO, пришлось повозиться.
16. ikorulev 20 03.03.21 09:09 Сейчас в теме
Спасибо, 3.1.17.94 - все работает, когда уже они все договорятся между собой про форматы
17. tank68 17 04.03.21 12:37 Сейчас в теме
По факту в ЗУП 3.1.17.94 выгрузка бумажного идет корректно, а вот с ЭЛН идет ошибка.
В частности для отправки в СБИС можно внести следующие изменения в процедуру "ЗаполнитьСтрокуРеестра" в менеджере объекта документа "Реестр прямых выплат ФСС", после этого ЭЛН будет выгружаться со всеми полями как больничный бумажный заполненный в программе.


//<<-- //НАЧ #  
	//Если Не СтруктураДанных.ЭтоЭЛН Или СтруктураДанных.ЭЛНКарантинПоКоронавирусу
	//	Или СтрНачинаетсяС(СтруктураДанных.НомерВходящегоДокумента, "9990") Тогда 
	//-->> //КОН # 
		
		Если СтруктураДанных.ВидВыплаты = "1" Или СтруктураДанных.ВидВыплаты = "2" Или СтруктураДанных.ВидВыплаты = "6" Тогда
			Если ЗначениеЗаполнено(СтруктураДанных.НомерПервичногоБольничного) Тогда
				ROW.PREV_LN_CODE = СтруктураДанных.НомерПервичногоБольничного;
				ROW.PRIMARY_FLAG = 0;
			Иначе
				ROW.PRIMARY_FLAG = 1;
			КонецЕсли;
			ROW.DUPLICATE_FLAG = Формат(СтруктураДанных.ЯвляетсяДубликатом, "БЛ=0; БИ=1");
			ROW.LN_DATE = Формат(СтруктураДанных.ДатаВыдачиБольничного, "ДФ=yyyy-MM-dd");
			ROW.LPU_NAME = СтруктураДанных.НаименованиеМедицинскойОрганизации;
			ROW.LPU_OGRN = СтруктураДанных.ОГРНМедицинскойОрганизации;
			ROW.REASON1 = СтруктураДанных.КодПричиныНетрудоспособности;
			Если СтруктураДанных.Совместительство Тогда
				ROW.PARENT_CODE = СтруктураДанных.НомерЛисткаПоОсновномуМестуРаботы;
			КонецЕсли;
			Если ЗначениеЗаполнено(СтруктураДанных.ПериодНахожденияВСтационареСРебенкомС) Или ЗначениеЗаполнено(СтруктураДанных.ПериодНахожденияВСтационареСРебенкомПо) Тогда
				ROW.HOSPITAL_DT1 = Формат(СтруктураДанных.ПериодНахожденияВСтационареСРебенкомС, "ДФ=yyyy-MM-dd");
				ROW.HOSPITAL_DT2 = Формат(СтруктураДанных.ПериодНахожденияВСтационареСРебенкомПо, "ДФ=yyyy-MM-dd");
			КонецЕсли;
			Если ЗначениеЗаполнено(СтруктураДанных.КодНарушенияРежима) И ЗначениеЗаполнено(СтруктураДанных.ДатаНарушенияРежима) Тогда
				ROW.HOSPITAL_BREACH_CODE = СтруктураДанных.КодНарушенияРежима;
				ROW.HOSPITAL_BREACH_DT   = Формат(СтруктураДанных.ДатаНарушенияРежима, "ДФ=yyyy-MM-dd");
			КонецЕсли;
			Если ЗначениеЗаполнено(СтруктураДанных.НовыйСтатусНетрудоспособного) Тогда
				ROW.MSE_RESULT = СтруктураДанных.НовыйСтатусНетрудоспособного;
				Если СтруктураДанных.НовыйСтатусНетрудоспособного = "31" Тогда
					ROW.NEXT_LN_CODE = СтруктураДанных.НомерЛисткаПродолжения;
				КонецЕсли;
			КонецЕсли;
			Если ЗначениеЗаполнено(СтруктураДанных.ОсвобождениеС1) Или ЗначениеЗаполнено(СтруктураДанных.ОсвобождениеПо1) Тогда
				ROW.TREAT1_DOCTOR_ROLE  = СтруктураДанных.ДолжностьВрача1;
				ROW.TREAT1_DOCTOR       = СтруктураДанных.ФИОВрача1;
				Если ЗначениеЗаполнено(СтруктураДанных.ДолжностьВрачаПредседателяВК1) Тогда
					ROW.TREAT1_DOCTOR2_ROLE = "ПРЕД ВК";
				КонецЕсли;
			КонецЕсли;
			Если ЗначениеЗаполнено(СтруктураДанных.ОсвобождениеС2) Или ЗначениеЗаполнено(СтруктураДанных.ОсвобождениеПо2) Тогда
				ROW.TREAT2_DT1          = Формат(СтруктураДанных.ОсвобождениеС2, "ДФ=yyyy-MM-dd");
				ROW.TREAT2_DT2          = Формат(СтруктураДанных.ОсвобождениеПо2, "ДФ=yyyy-MM-dd");
				ROW.TREAT2_DOCTOR_ROLE  = СтруктураДанных.ДолжностьВрача2;
				ROW.TREAT2_DOCTOR       = СтруктураДанных.ФИОВрача2;
				Если ЗначениеЗаполнено(СтруктураДанных.ДолжностьВрачаПредседателяВК2) Тогда
					ROW.TREAT2_DOCTOR2_ROLE = "ПРЕД ВК";
				КонецЕсли;
			КонецЕсли;
			Если ЗначениеЗаполнено(СтруктураДанных.ОсвобождениеС3) Или ЗначениеЗаполнено(СтруктураДанных.ОсвобождениеПо3) Тогда
				ROW.TREAT3_DT1          = Формат(СтруктураДанных.ОсвобождениеС3, "ДФ=yyyy-MM-dd");
				ROW.TREAT3_DT2          = Формат(СтруктураДанных.ОсвобождениеПо3, "ДФ=yyyy-MM-dd");
				ROW.TREAT3_DOCTOR_ROLE  = СтруктураДанных.ДолжностьВрача3;
				ROW.TREAT3_DOCTOR       = СтруктураДанных.ФИОВрача3;
				Если ЗначениеЗаполнено(СтруктураДанных.ДолжностьВрачаПредседателяВК3) Тогда
					ROW.TREAT3_DOCTOR2_ROLE = "ПРЕД ВК";
				КонецЕсли;
			КонецЕсли;
			ROW.OTHER_STATE_DT 			= Формат(СтруктураДанных.ДатаНовыйСтатусНетрудоспособного, "ДФ=yyyy-MM-dd");
			ROW.RETURN_DATE_LPU 		= Формат(СтруктураДанных.ДатаВыходаНаРаботу, "ДФ=yyyy-MM-dd");
		КонецЕсли;
		
		Если СтруктураДанных.ВидВыплаты = "1" Или СтруктураДанных.ВидВыплаты = "2" Тогда
			ROW.DATE1 = Формат(СтруктураДанных.ДатаИзмененияКодаПричиныНетрудоспособности, "ДФ=yyyy-MM-dd");
			ROW.DATE2 = Формат(СтруктураДанных.ДатаОкончанияПутевки, "ДФ=yyyy-MM-dd");
			Если ЗначениеЗаполнено(СтруктураДанных.УходЗаРодственникомФИО1) Тогда
				ROW.SERV1_AGE 			= СтруктураДанных.УходЗаРодственникомЛет1;
				ROW.SERV1_MM 			= СтруктураДанных.УходЗаРодственникомМесяцев1;
				ROW.SERV1_RELATION_CODE = СтруктураДанных.УходЗаРодственникомРодственнаяСвязь1;
				ROW.SERV1_FIO 			= СтруктураДанных.УходЗаРодственникомФИО1;
			КонецЕсли;
			Если ЗначениеЗаполнено(СтруктураДанных.УходЗаРодственникомФИО2) Тогда
				ROW.SERV2_AGE 			= СтруктураДанных.УходЗаРодственникомЛет2;
				ROW.SERV2_MM 			= СтруктураДанных.УходЗаРодственникомМесяцев2;
				ROW.SERV2_RELATION_CODE = СтруктураДанных.УходЗаРодственникомРодственнаяСвязь2;
				ROW.SERV2_FIO 			= СтруктураДанных.УходЗаРодственникомФИО2;
			КонецЕсли;
			Если ЗначениеЗаполнено(СтруктураДанных.ДатаИзмененияКодаПричиныНетрудоспособности)
				И (СтруктураДанных.ДополнительныйКодПричиныНетрудоспособности = "017"
					Или СтруктураДанных.ДополнительныйКодПричиныНетрудоспособности = "018"
					Или СтруктураДанных.ДополнительныйКодПричиныНетрудоспособности = "019") Тогда
				ROW.VOUCHER_OGRN = СтруктураДанных.ОГРН_Санатория;
			КонецЕсли;
		КонецЕсли;
		
	//<<-- //НАЧ #
	//КонецЕсли;
	//-->> //КОН #	

Показать
Olga_Mil; Hla; +2 Ответить
18. ameer83 04.03.21 15:44 Сейчас в теме
(17) Вы это предлагаете для типовой конфигурации для формата 1.7.7, или для данного расширения?
19. tank68 17 05.03.21 14:17 Сейчас в теме
(18) Это для ЗУП 3.1.17.94
Можно просто поправить процедуру
Или добавить в расширение ниже приведен полный текст процедуры


Процедура ЗаполнитьСтрокуРеестра(ROW, СтруктураДанных)
	
	Если Не СтруктураДанных.Перерасчет Тогда
		ROW.TYPE_INFO = "0";
	Иначе
		ROW.TYPE_INFO = "1";
		ROW.RECALC_REASON_CODE = Число("0"+СтруктураДанных.КодПричиныПерерасчета);
	КонецЕсли;
	
	Если СтруктураДанных.ВидВыплаты = "1" Тогда
		
	КонецЕсли;
	
	ROW.DOC_TYPE   = СтруктураДанных.ВидВыплаты;
	ROW.DOC_DT1    = СтруктураДанных.ДатаПредставленияПакетаДокументов;
	ROW.SNILS      = СтрЗаменить(СтрЗаменить(СтруктураДанных.СтраховойНомерПФР, "-","")," ","");
	ROW.INN_PERSON = СтруктураДанных.ИНН;
	ROW.SURNAME    = СтруктураДанных.Фамилия;
	ROW.NAME       = СтруктураДанных.Имя;
	ROW.PATRONIMIC = СтруктураДанных.Отчество;
	
	ЗаполнитьСтатусНалогоплательщикаВСтрокеРеестра(ROW, СтруктураДанных);
	
	ROW.RESIDENT_CODE = СтруктураДанных.КодСтраны;
	ROW.BIRTHDAY      = СтруктураДанных.ДатаРождения;
	ROW.GENDER        = Формат(СтруктураДанных.Пол = Перечисления.ПолФизическогоЛица.Женский, "БЛ=0; БИ=1");
	
	Если ЗначениеЗаполнено(СтруктураДанных.КодМВДДокументаНаПроживание)
		И ЗначениеЗаполнено(СтруктураДанных.СерияДокументаНаПроживание + " " + СтруктураДанных.НомерДокументаНаПроживание)
		И ЗначениеЗаполнено(СтруктураДанных.ДатаВыдачиДокументаНаПроживание)
		И ЗначениеЗаполнено(СтруктураДанных.КемВыданДокументНаПроживание)
		И ЗначениеЗаполнено(СтруктураДанных.Гражданство)
		И СтруктураДанных.Гражданство <> ОбщегоНазначения.ПредопределенныйЭлемент("Справочник.СтраныМира.Россия") Тогда
		
		ROW.ID_TYPE = СтруктураДанных.КодМВДДокументаНаПроживание;
		ROW.ID_NO   = СтруктураДанных.СерияДокументаНаПроживание + " " + СтруктураДанных.НомерДокументаНаПроживание;
		ROW.ID_DT   = СтруктураДанных.ДатаВыдачиДокументаНаПроживание;
		ROW.ID_DEPT = СокрЛП(СтруктураДанных.КемВыданДокументНаПроживание);
		
	Иначе
		
		ROW.ID_TYPE = СтруктураДанных.ВидУдостоверенияЛичности;
		ROW.ID_NO   = СтруктураДанных.СерияДокумента + " " + СтруктураДанных.НомерДокумента;
		ROW.ID_DT   = СтруктураДанных.ДатаВыдачиДокумента;
		ROW.ID_DEPT = СокрЛП(СтруктураДанных.КемВыданДокумент);
		
	КонецЕсли;
	
	ROW.OWNER_FLAG = 1;
	ROW.EMPL_FLAG = Формат(СтруктураДанных.Совместительство, "БЛ=1; БИ=0");
	
	// Приказ страхователя:
	// 1 - о досрочном выходе на работу;
	// 2 - о прекращении трудовых отношений.
	Если СтруктураДанных.ДосрочноеПрекращениеОтпускаПоУходуТипПриказа = Перечисления.СостоянияСотрудника.Работа Тогда
		HOLID_TYPE = "1";
	ИначеЕсли СтруктураДанных.ДосрочноеПрекращениеОтпускаПоУходуТипПриказа = Перечисления.СостоянияСотрудника.Увольнение Тогда
		HOLID_TYPE = "2";
	Иначе
		HOLID_TYPE = Неопределено;
	КонецЕсли;
	Если HOLID_TYPE <> Неопределено Тогда
		ROW.HOLID_TYPE  = HOLID_TYPE;
		ROW.HOLID_NO    = СтруктураДанных.ДосрочноеПрекращениеОтпускаПоУходуНомерПриказа;
		ROW.HOLID_DT    = СтруктураДанных.ДосрочноеПрекращениеОтпускаПоУходуДатаПриказа;
		ROW.HOLID_DT_EX = СтруктураДанных.ДосрочноеПрекращениеОтпускаПоУходуДатаПрекращенияОплаты;
	КонецЕсли;
	
	// Извещение о представлении недостающих сведений в ФСС;
	// Решение об отказе в назначении пособия:
	Если СтруктураДанных.ИзвещениеИзФССИспользование Тогда
		ROW.RESP_NO = СтруктураДанных.ИзвещениеИзФССНомер;
		ROW.RESP_DT = СтруктураДанных.ИзвещениеИзФССДата;
	КонецЕсли;
	
	Если СтруктураДанных.СпособВыплатыПособия = Перечисления.СпособыВыплатыПособия.ПочтовымПереводом Тогда
		
		ROW.PAYMENT_TYPE = "0"; // Способ выплаты: почтовый перевод.
		
		ОписаниеАдреса = СтруктураАдреса(СтруктураДанных.АдресПолучателяФактический);
		
		ROW.POST_INDEX 		= ОписаниеАдреса.Индекс;
		ROW.ADDR_A1 		= ОписаниеАдреса.Регион;
		ROW.ADDR_A2 		= ОписаниеАдреса.Район;
		ROW.ADDR_A3 		= ОписаниеАдреса.Город;
		ROW.ADDR_A4 		= ОписаниеАдреса.НаселенныйПункт;
		ROW.ADDR_PLAN 		= ОписаниеАдреса.Территория;
		ROW.ADDR_A5 		= ОписаниеАдреса.Улица;
		ROW.ADDR_HOUSE 		= ОписаниеАдреса.Дом;
		ROW.ADDR_BUILDING 	= ОписаниеАдреса.Корпус;
		ROW.ADDR_FLAT 		= ОписаниеАдреса.Квартира;
		
		ROW.ADDR_KLADR 		= СтруктураДанных.АдресПолучателяФактическийКодКЛАДР;
		ROW.ADDR_GUID 		= СтруктураДанных.АдресПолучателяФактическийИдентификаторФИАС;
		
	ИначеЕсли СтруктураДанных.СпособВыплатыПособия = Перечисления.СпособыВыплатыПособия.ЧерезБанк Тогда
		
		ROW.PAYMENT_TYPE = "1"; // Способ выплаты: банковский счет (расчетный счет).
		ROW.ACCOUNT_BIC  = СтруктураДанных.БИКБанка;
		ROW.ACCOUNT_NAME = СтруктураДанных.НаименованиеБанка;
		ROW.ACCOUNT      = ОставитьТолькоЦифрыВСтроке(СтруктураДанных.НомерЛицевогоСчета);
		
	ИначеЕсли СтруктураДанных.СпособВыплатыПособия = Перечисления.СпособыВыплатыПособия.НаКартуМИР Тогда
		
		ROW.PAYMENT_TYPE = "2"; // Способ выплаты: банковский счет (карта МИР).
		ROW.PAYCARD_NUM  = БанковскиеКарты.ПолныйНомерКарты(СтруктураДанных.КартаМИР);
		
	КонецЕсли;
	
	Если ЗначениеЗаполнено(СтруктураДанных.АдресПолучателяРегистрации) Тогда
		Если ROW.RESIDENT_FLAG = 1 Тогда
			
			ОписаниеАдреса = СтруктураАдреса(СтруктураДанных.АдресПолучателяРегистрации);
			
			ROW.POST_INDEX2 		= ОписаниеАдреса.Индекс;
			ROW.ADDR2_A1 			= ОписаниеАдреса.Регион;
			ROW.ADDR2_A2 			= ОписаниеАдреса.Район;
			ROW.ADDR2_A3 			= ОписаниеАдреса.Город;
			ROW.ADDR2_A4 			= ОписаниеАдреса.НаселенныйПункт;
			ROW.ADDR2_PLAN 			= ОписаниеАдреса.Территория;
			ROW.ADDR2_A5 			= ОписаниеАдреса.Улица;
			ROW.ADDR2_HOUSE 		= ОписаниеАдреса.Дом;
			ROW.ADDR2_BUILDING 		= ОписаниеАдреса.Корпус;
			ROW.ADDR2_FLAT 			= ОписаниеАдреса.Квартира;
			
			ROW.ADDR2_KLADR 		= СтруктураДанных.АдресПолучателяРегистрацииКодКЛАДР;
			ROW.ADDR2_GUID 			= СтруктураДанных.АдресПолучателяРегистрацииИдентификаторФИАС;
			
		Иначе
			
			ТипАдреса = Справочники.ВидыКонтактнойИнформации.АдресПоПропискеФизическиеЛица;
			ROW.ADDR2 = УправлениеКонтактнойИнформацией.ПредставлениеКонтактнойИнформации(СтруктураДанных.АдресПолучателяРегистрации, ТипАдреса);
			
		КонецЕсли;
	КонецЕсли;
		
	Если СтруктураДанных.РайонныйКоэффициент >= 1.10 И СтруктураДанных.РайонныйКоэффициент <= 3 Тогда
		ROW.KF_REG = СтруктураДанных.РайонныйКоэффициент * 100;
	Иначе
		ROW.KF_REG = 100;
	КонецЕсли;
	
	Если СтруктураДанных.ВидВыплаты = "1" Или СтруктураДанных.ВидВыплаты = "2" Тогда
		Если ЗначениеЗаполнено(СтруктураДанных.ПериодПростояС1) Или ЗначениеЗаполнено(СтруктураДанных.ПериодПростояПо1)
			Или ЗначениеЗаполнено(СтруктураДанных.ПериодПростояС2) Или ЗначениеЗаполнено(СтруктураДанных.ПериодПростояПо2) Тогда
			
			ТипPERIODS = ROW.Свойства().Получить("PERIODS").Тип;
			PERIODS = ФабрикаXDTO.Создать(ТипPERIODS);
			
			ТипPERIOD = PERIODS.Свойства().Получить("PERIOD").Тип;
			
			Если ЗначениеЗаполнено(СтруктураДанных.ПериодПростояС1) Или ЗначениеЗаполнено(СтруктураДанных.ПериодПростояПо1) Тогда
				
				PERIOD = ФабрикаXDTO.Создать(ТипPERIOD);
				
				PERIOD.START_DATE 	= Формат(СтруктураДанных.ПериодПростояС1, "ДФ=yyyy-MM-dd");
				PERIOD.END_DATE 	= Формат(СтруктураДанных.ПериодПростояПо1, "ДФ=yyyy-MM-dd");
				PERIOD.IDLE_AVERAGE = СтруктураДанных.СреднийЗаработокНаПериодПростоя1;
				
				PERIODS.PERIOD.Добавить(PERIOD);
				
			КонецЕсли;
			
			Если ЗначениеЗаполнено(СтруктураДанных.ПериодПростояС2) Или ЗначениеЗаполнено(СтруктураДанных.ПериодПростояПо2) Тогда
				
				PERIOD = ФабрикаXDTO.Создать(ТипPERIOD);
				
				PERIOD.START_DATE 	= Формат(СтруктураДанных.ПериодПростояС2, "ДФ=yyyy-MM-dd");
				PERIOD.END_DATE 	= Формат(СтруктураДанных.ПериодПростояПо2, "ДФ=yyyy-MM-dd");
				PERIOD.IDLE_AVERAGE = СтруктураДанных.СреднийЗаработокНаПериодПростоя2;
				
				PERIODS.PERIOD.Добавить(PERIOD);
				
			КонецЕсли;
			
			ROW.PERIODS.Добавить(PERIODS);
			
		КонецЕсли;
		
		РазностьСтажей = УчетПособийСоциальногоСтрахования.ПодсчитатьРазностьСтажейВГодахИМесяцах(
			СтруктураДанных.СтажРасширенныйЛет,
			СтруктураДанных.СтажРасширенныйМесяцев,
			СтруктураДанных.СтажЛет,
			СтруктураДанных.СтажМесяцев);
		Если РазностьСтажей.РазностьЛет <> 0 Или РазностьСтажей.РазностьМесяцев <> 0 Тогда
			ROW.INSUR_YY = СтруктураДанных.СтажРасширенныйЛет;
			ROW.INSUR_MM = СтруктураДанных.СтажРасширенныйМесяцев;
			ROW.NOT_INSUR_YY = РазностьСтажей.РазностьЛет;
			ROW.NOT_INSUR_MM = РазностьСтажей.РазностьМесяцев;
		Иначе
			ROW.INSUR_YY = СтруктураДанных.СтажЛет;
			ROW.INSUR_MM = СтруктураДанных.СтажМесяцев;
		КонецЕсли;
		
		ROW.LN_CODE = СтруктураДанных.НомерВходящегоДокумента;
		ROW.LN_TYPE = Формат(СтруктураДанных.ЭтоЭЛН, "БЛ=0; БИ=1");
		
		ROW.LPU_ADDRESS    = СтруктураДанных.АдресМедицинскойОрганизации;
		
		ROW.REASON2        = СтруктураДанных.ДополнительныйКодПричиныНетрудоспособности;
		ROW.REASON3        = СтруктураДанных.ВторойКодПричиныНетрудоспособности;
		ROW.VOUCHER_NO 		= СтруктураДанных.НомерПутевки;
		
		Если ЗначениеЗаполнено(СтруктураДанных.УходЗаРодственникомФИО1) Тогда
			ROW.SERV1_DAYS 			= СтруктураДанных.УходЗаРодственникомИспользованоДней1;
		КонецЕсли;
		Если ЗначениеЗаполнено(СтруктураДанных.УходЗаРодственникомФИО2) Тогда
			ROW.SERV2_DAYS 			= СтруктураДанных.УходЗаРодственникомИспользованоДней2;
		КонецЕсли;
		ROW.MSE_DT1 = Формат(СтруктураДанных.ДатаНаправленияВБюроМСЭ, "ДФ=yyyy-MM-dd");
		ROW.MSE_DT2 = Формат(СтруктураДанных.ДатаРегистрацииДокументовМСЭ, "ДФ=yyyy-MM-dd");
		ROW.MSE_DT3 = Формат(СтруктураДанных.ДатаОсвидетельствованияМСЭ, "ДФ=yyyy-MM-dd");
		Если ЗначениеЗаполнено(СтруктураДанных.ГруппаИнвалидности) Тогда
			ROW.MSE_INVALID_GROUP = СтруктураДанных.ГруппаИнвалидности;
		КонецЕсли;
		Если ЗначениеЗаполнено(СтруктураДанных.ДнейБолезниИнвалида) Тогда
			ROW.MSE_INVALID_DAYS = СтруктураДанных.ДнейБолезниИнвалида;
		КонецЕсли;

		Если ЗначениеЗаполнено(СтруктураДанных.ОсвобождениеС1) Или ЗначениеЗаполнено(СтруктураДанных.ОсвобождениеПо1) Тогда
			ROW.TREAT1_DT1          = Формат(СтруктураДанных.ОсвобождениеС1, "ДФ=yyyy-MM-dd");
			ROW.TREAT1_DT2          = Формат(СтруктураДанных.ОсвобождениеПо1, "ДФ=yyyy-MM-dd");
			ROW.TREAT1_DOC_ID       = СтруктураДанных.ИдентификационныйНомерВрача1;
			ROW.TREAT1_CHAIRMAN_VK  = СтруктураДанных.ФИОВрачаПредседателяВК1;
			ROW.TREAT1_DOC2_ID      = СтруктураДанных.ИдентификационныйНомерВрачаПредседателяВК1;
		КонецЕсли;
		Если ЗначениеЗаполнено(СтруктураДанных.ОсвобождениеС2) Или ЗначениеЗаполнено(СтруктураДанных.ОсвобождениеПо2) Тогда
			ROW.TREAT2_DOC_ID       = СтруктураДанных.ИдентификационныйНомерВрача2;
			ROW.TREAT2_CHAIRMAN_VK  = СтруктураДанных.ФИОВрачаПредседателяВК2;
			ROW.TREAT2_DOC2_ID      = СтруктураДанных.ИдентификационныйНомерВрачаПредседателяВК2;
		КонецЕсли;
		Если ЗначениеЗаполнено(СтруктураДанных.ОсвобождениеС3) Или ЗначениеЗаполнено(СтруктураДанных.ОсвобождениеПо3) Тогда
			ROW.TREAT3_DOC_ID       = СтруктураДанных.ИдентификационныйНомерВрача3;
			ROW.TREAT3_CHAIRMAN_VK  = СтруктураДанных.ФИОВрачаПредседателяВК3;
			ROW.TREAT3_DOC2_ID      = СтруктураДанных.ИдентификационныйНомерВрачаПредседателяВК3;
		КонецЕсли;
		ROW.CALC_CONDITION1 		= СтруктураДанных.УсловияИсчисленияКод1;
		ROW.CALC_CONDITION2 		= СтруктураДанных.УсловияИсчисленияКод2;
		ROW.CALC_CONDITION3 		= СтруктураДанных.УсловияИсчисленияКод3;
		Если СтруктураДанных.УсловияИсчисленияКод1 = "43" Или СтруктураДанных.УсловияИсчисленияКод2 = "43" Или СтруктураДанных.УсловияИсчисленияКод3 = "43" Тогда
			Если СтруктураДанных.ВыплатаЗаСчетФедеральногоБюджета = Перечисления.ОснованияФинансированияПособияФедеральнымБюджетом.Чернобыль Тогда
				ROW.CODE_NUCLEAR 	= 1;
			ИначеЕсли СтруктураДанных.ВыплатаЗаСчетФедеральногоБюджета = Перечисления.ОснованияФинансированияПособияФедеральнымБюджетом.Семипалатинск Тогда
				ROW.CODE_NUCLEAR 	= 2;
			ИначеЕсли СтруктураДанных.ВыплатаЗаСчетФедеральногоБюджета = Перечисления.ОснованияФинансированияПособияФедеральнымБюджетом.Маяк Тогда
				ROW.CODE_NUCLEAR 	= 3;
			ИначеЕсли СтруктураДанных.ВыплатаЗаСчетФедеральногоБюджета = Перечисления.ОснованияФинансированияПособияФедеральнымБюджетом.ПодразделенияОсобогоРиска Тогда
				ROW.CODE_NUCLEAR	= 4;
			КонецЕсли;
		КонецЕсли;
		Если ЗначениеЗаполнено(СтруктураДанных.ДатаАктаФормыН1) Тогда
			ROW.FORM1_DT 			= Формат(СтруктураДанных.ДатаАктаФормыН1, "ДФ=yyyy-MM-dd");
		КонецЕсли;
		Если ЗначениеЗаполнено(СтруктураДанных.ДатаНачалаРаботы) Тогда
			ROW.RETURN_DATE_EMPL 	= Формат(СтруктураДанных.ДатаНачалаРаботы, "ДФ=yyyy-MM-dd");
		КонецЕсли;
		Если ЗначениеЗаполнено(СтруктураДанных.СрочныйДоговорС) И ЗначениеЗаполнено(СтруктураДанных.СрочныйДоговорПо) Тогда
			ROW.WORK_CONTRACT_START_DT 	= Формат(СтруктураДанных.СрочныйДоговорС, "ДФ=yyyy-MM-dd");
			ROW.WORK_CONTRACT_FINISH_DT = Формат(СтруктураДанных.СрочныйДоговорПо, "ДФ=yyyy-MM-dd");
		КонецЕсли;
		ROW.FSS_PAYMENT_FLAG = ?(ЗначениеЗаполнено(СтруктураДанных.ДатаНачалаОплаты), 1, 0);
		Если ЗначениеЗаполнено(СтруктураДанных.ДатаНачалаОплаты) Тогда
			ROW.DT1 = Формат(СтруктураДанных.ДатаНачалаОплаты, "ДФ=yyyy-MM-dd");
			ROW.DT2 = Формат(СтруктураДанных.ДатаОкончанияОплаты, "ДФ=yyyy-MM-dd");
		КонецЕсли;		
		Если ЗначениеЗаполнено(СтруктураДанных.СуммаПособияРаботодателя) Тогда
			ROW.EMPL_PAYMENT 	= СтруктураДанных.СуммаПособияРаботодателя;
		КонецЕсли;
		Если ЗначениеЗаполнено(СтруктураДанных.СуммаПособияФСС) Тогда
			ROW.FSS_PAYMENT		= СтруктураДанных.СуммаПособияФСС;
		КонецЕсли;
		Если ЗначениеЗаполнено(СтруктураДанных.СуммаПособияВсего) Тогда
			ROW.PAYMENT 		= СтруктураДанных.СуммаПособияВсего;
		КонецЕсли;
	КонецЕсли;
	
	Если СтруктураДанных.ВидВыплаты = "1" Или СтруктураДанных.ВидВыплаты = "2" Или СтруктураДанных.ВидВыплаты = "5" Тогда
		ROW.BASE_AVG_DAILY_SAL = СтруктураДанных.СреднийЗаработокЗаРасчетныйПериод;
		Если СтруктураДанных.ПорядокРасчетаСреднегоЗаработка = Перечисления.СпособыРасчетаСреднегоЗаработкаДляОплатыПособия.СреднийЗаработок Тогда
			ROW.YEAR1 = СтруктураДанных.ПервыйГодРасчета;
			ROW.YEAR2 = СтруктураДанных.ВторойГодРасчета;
			
			Если СтруктураДанных.ЗамененыКалендарныеГодыРасчетаСреднегоЗаработка Тогда
				ROW.YEAR_CHANGE_FLAG = 1;
				ROW.YEAR1_OLD = СтруктураДанных.ЗамененныйПервыйГодРасчета;
				ROW.YEAR2_OLD = СтруктураДанных.ЗамененныйВторойГодРасчета;
			Иначе
				ROW.YEAR_CHANGE_FLAG = 0;
			КонецЕсли;
			
			ROW.BASE_CALC_DAYS = СтруктураДанных.КалендарныхДнейРасчетногоПериода;
			ROW.BASE_SUM1 = СтруктураДанных.ЗаработокПервыйГодРасчета;
			ROW.BASE_SUM2 = СтруктураДанных.ЗаработокВторойГодРасчета;
			ROW.BASE_AVG_SAL = СреднийЗаработокЗаДваКалендарныхГода(СтруктураДанных);
		КонецЕсли;
		Если СтруктураДанных.ДоляВремени > 0 И СтруктураДанных.ДоляВремени < 1 Тогда
			ROW.KF_SHORT_DAY = Окр(СтруктураДанных.ДоляВремени, 3);
		Иначе
			ROW.KF_SHORT_DAY = 1;
		КонецЕсли;
	КонецЕсли;
	
	Если СтруктураДанных.ВидВыплаты = "2" Тогда
		ROW.PREGN12W_FLAG = "0";
		Если СтруктураДанных.ВидПособия = Перечисления.ПособияНазначаемыеФСС.ПособиеПоБеременностиИРодам Тогда
			Если СтруктураДанных.ПоставленаНаУчетВРанниеСрокиБеременности = Перечисления.ПостановкаНаУчетВРанниеСрокиБеременности.НеИзвестно Тогда
				ROW.PREGN12W_FLAG = "2";
			ИначеЕсли СтруктураДанных.ПоставленаНаУчетВРанниеСрокиБеременности = Перечисления.ПостановкаНаУчетВРанниеСрокиБеременности.Поставлена Тогда
				ROW.PREGN12W_FLAG = "1";
			КонецЕсли;
		КонецЕсли;
	КонецЕсли;
		
	Если СтруктураДанных.ВидВыплаты = "3" 
		Или (СтруктураДанных.ВидВыплаты = "2" И СтруктураДанных.ПоставленаНаУчетВРанниеСрокиБеременности = Перечисления.ПостановкаНаУчетВРанниеСрокиБеременности.Поставлена) Тогда
		ROW.REF_12WEEK_NO = СтруктураДанных.НомерСправкиБеременной;
		ROW.REF_12WEEK_DT = Формат(СтруктураДанных.ДатаСправкиБеременной, "ДФ=yyyy-MM-dd");
	КонецЕсли;
	
	Если СтруктураДанных.ВидВыплаты = "4" Тогда
		
		Если ЗначениеЗаполнено(СтруктураДанных.ВидСправкиОРожденииРебенка) И ЗначениеЗаполнено(СтруктураДанных.НомерСправки) И ЗначениеЗаполнено(СтруктураДанных.ДатаСправки) Тогда
			Если СтруктураДанных.ВидСправкиОРожденииРебенка = Перечисления.ФормыСправкиОРожденииРебенка.Форма24 Тогда
				ВидСправкиОРожденииРебенка = "24"; 
			ИначеЕсли СтруктураДанных.ВидСправкиОРожденииРебенка = Перечисления.ФормыСправкиОРожденииРебенка.Форма25 Тогда
				ВидСправкиОРожденииРебенка = "25"; 
			ИначеЕсли СтруктураДанных.ВидСправкиОРожденииРебенка = Перечисления.ФормыСправкиОРожденииРебенка.Форма26 Тогда
				ВидСправкиОРожденииРебенка = "26"; 
			ИначеЕсли СтруктураДанных.ВидСправкиОРожденииРебенка = Перечисления.ФормыСправкиОРожденииРебенка.Форма1 Тогда
				ВидСправкиОРожденииРебенка = "48";
			ИначеЕсли СтруктураДанных.ВидСправкиОРожденииРебенка = Перечисления.ФормыСправкиОРожденииРебенка.Форма2 Тогда
				ВидСправкиОРожденииРебенка = "49";
			ИначеЕсли СтруктураДанных.ВидСправкиОРожденииРебенка = Перечисления.ФормыСправкиОРожденииРебенка.Форма3 Тогда
				ВидСправкиОРожденииРебенка = "50";
			ИначеЕсли СтруктураДанных.ВидСправкиОРожденииРебенка = Перечисления.ФормыСправкиОРожденииРебенка.Форма4 Тогда
				ВидСправкиОРожденииРебенка = "51"; 
			КонецЕсли;	
			ROW.REF_TYPE = ВидСправкиОРожденииРебенка;
			ROW.REF_24_NO = СтруктураДанных.НомерСправки;
			ROW.REF_24_DT = Формат(СтруктураДанных.ДатаСправки, "ДФ=yyyy-MM-dd");
		Иначе 	
			Если ЗначениеЗаполнено(СтруктураДанных.ДокументОРожденииДатаВыдачи) Тогда
				ROW.O_CERT_NO = СтруктураДанных.ДокументОРожденииСерияНомер;
				ROW.O_CERT_DT = Формат(СтруктураДанных.ДокументОРожденииДатаВыдачи, "ДФ=yyyy-MM-dd");
			Иначе
				ROW.O_CERT_NO = ?(ЗначениеЗаполнено(СтруктураДанных.НомерИногоПодтвержденияРождения), СтруктураДанных.НомерИногоПодтвержденияРождения, "00000000");
				ROW.O_CERT_DT = ?(ЗначениеЗаполнено(СтруктураДанных.ДатаИногоПодтвержденияРождения), Формат(СтруктураДанных.ДатаИногоПодтвержденияРождения, "ДФ=yyyy-MM-dd"), Формат(СтруктураДанных.ДатаРожденияРебенка, "ДФ=yyyy-MM-dd"));								
			КонецЕсли;
		КонецЕсли;
		Если ЗначениеЗаполнено(СтруктураДанных.НомерДоговораОПередачеНаВоспитание) И ЗначениеЗаполнено(СтруктураДанных.ДатаДоговораОПередачеНаВоспитание) Тогда
			ROW.REF_FAMILY_NO = СтруктураДанных.НомерДоговораОПередачеНаВоспитание;
			ROW.REF_FAMILY_DT = Формат(СтруктураДанных.ДатаДоговораОПередачеНаВоспитание, "ДФ=yyyy-MM-dd");
		КонецЕсли;
		ROW.REF_NPAY_OTHER_NO = СтруктураДанных.НомерСправкиОтДругогоРодителя;
		ROW.REF_NPAY_OTHER_DT = Формат(СтруктураДанных.ДатаСправкиОтДругогоРодителя, "ДФ=yyyy-MM-dd"); 
		
	КонецЕсли;
	
	Если СтруктураДанных.ВидВыплаты = "2" Тогда
		
		ROW.HOLID_DT_ST = Формат(СтруктураДанных.ОсвобождениеС1 , "ДФ=yyyy-MM-dd");
		ROW.HOLID_DT_FN = Формат(СтруктураДанных.ОсвобождениеПо1, "ДФ=yyyy-MM-dd");
	КонецЕсли;
	
	Если СтруктураДанных.ВидВыплаты = "5" Тогда
		
		ROW.HOLID_DT_ST = Формат(СтруктураДанных.ДатаНачала, "ДФ=yyyy-MM-dd");
		ROW.HOLID_DT_FN = Формат(СтруктураДанных.ДатаОкончания, "ДФ=yyyy-MM-dd");
	КонецЕсли;
	
	Если СтруктураДанных.ВидВыплаты = "2" Или СтруктураДанных.ВидВыплаты = "5" Тогда
		
		ROW.HOLID_ORD_NO = СтруктураДанных.НомерПриказаНаОтпускПоУходуЗаРебенком;
		ROW.HOLID_ORD_DT = ?(ЗначениеЗаполнено(СтруктураДанных.ДатаПриказаНаОтпускПоУходуЗаРебенком), Формат(СтруктураДанных.ДатаПриказаНаОтпускПоУходуЗаРебенком, "ДФ=yyyy-MM-dd"), "");
	КонецЕсли;
	
	Если СтруктураДанных.ВидВыплаты = "4" Или СтруктураДанных.ВидВыплаты = "5" Тогда
		
		ROW.CERT_BR = Формат(СтруктураДанных.ДатаРожденияРебенка, "ДФ=yyyy-MM-dd");
		ROW.CERT_SURNAME = СтруктураДанных.ФамилияРебенка;
		ROW.CERT_NAME = СтруктураДанных.ИмяРебенка;
		ROW.CERT_PATRONIMIC = СтруктураДанных.ОтчествоРебенка;
		Если ЗначениеЗаполнено(СтруктураДанных.УсыновлениеОпека) Тогда
			ROW.WARD_FLAG = СтруктураДанных.УсыновлениеОпека;
			ROW.WARD_REF_NO = СтруктураДанных.УсыновлениеОпекаСерияНомер;
			ROW.WARD_REF_DT = Формат(СтруктураДанных.УсыновлениеОпекаДатаВыдачи,"ДФ=yyyy-MM-dd");
		КонецЕсли;
	КонецЕсли;
	
	Если СтруктураДанных.ВидВыплаты = "5" Тогда
		
		ROW.MULTPATR = Формат(СтруктураДанных.ОдновременныйУходЗаНесколькимиДетьми,"БЛ=0; БИ=1");
		ROW.CHILD_SER = СтруктураДанных.Очередность;
		ROW.MH_OUT = Формат(СтруктураДанных.НаличиеРешенияСудаОЛишенииПрав,"БЛ=0; БИ=1");
		ROW.OTHER_CHILD_FLAG_DT = Формат(СтруктураДанных.НаличиеДокументаОСмерти,"БЛ=0; БИ=1");
		ROW.OTHER_CHILD_FLAG_BR = Формат(СтруктураДанных.НаличиеДокументаОРождении,"БЛ=0; БИ=1");
		
		Если СтруктураДанных.ДокументОРожденииВид = Перечисления.ВидыПодтверждающихДокументовОтпускаПоУходу.СвидетельствоОРождении Тогда
			ROW.CERT_NO = СтруктураДанных.ДокументОРожденииСерияНомер;
			ROW.CERT_DT = Формат(СтруктураДанных.ДокументОРожденииДатаВыдачи, "ДФ=yyyy-MM-dd");
		Иначе
			Если ЗначениеЗаполнено(СтруктураДанных.ДокументОРожденииДатаВыдачи) Тогда
				ROW.O_CERT_NO = СтруктураДанных.ДокументОРожденииСерияНомер;
				ROW.O_CERT_DT = Формат(СтруктураДанных.ДокументОРожденииДатаВыдачи, "ДФ=yyyy-MM-dd");
			Иначе
				ROW.O_CERT_NO = ?(ЗначениеЗаполнено(СтруктураДанных.НомерИногоПодтвержденияРождения), СтруктураДанных.НомерИногоПодтвержденияРождения, "00000000");
				ROW.O_CERT_DT = ?(ЗначениеЗаполнено(СтруктураДанных.ДатаИногоПодтвержденияРождения), Формат(СтруктураДанных.ДатаИногоПодтвержденияРождения, "ДФ=yyyy-MM-dd"), Формат(СтруктураДанных.ДатаРожденияРебенка, "ДФ=yyyy-MM-dd"));								
			КонецЕсли;
		КонецЕсли;
		Если СтруктураДанных.ОдновременныйУходЗаНесколькимиДетьми Тогда
			ROW.AVG_SAL = Окр(СтруктураДанных.СреднийЗаработокЗаРасчетныйПериод * 30.4, 2);
		КонецЕсли;
		Если ЗначениеЗаполнено(СтруктураДанных.НомерПриказаОЗаменеПослеродовогоОтпуска) И ЗначениеЗаполнено(СтруктураДанных.ДатаПриказаОЗаменеПослеродовогоОтпуска) Тогда
			ROW.HOLID_CH_ORD_NO = СтруктураДанных.НомерПриказаОЗаменеПослеродовогоОтпуска;
			ROW.HOLID_CH_ORD_DT = Формат(СтруктураДанных.ДатаПриказаОЗаменеПослеродовогоОтпуска, "ДФ=yyyy-MM-dd");
		КонецЕсли;
		Если ЗначениеЗаполнено(СтруктураДанных.НомерСправкиОНеполученииПособияОтОтца) И ЗначениеЗаполнено(СтруктураДанных.ДатаСправкиОНеполученииПособияОтОтца) Тогда
			ROW.REF_NPAY_FATHER_NO = СтруктураДанных.НомерСправкиОНеполученииПособияОтОтца;
			ROW.REF_NPAY_FATHER_DT = Формат(СтруктураДанных.ДатаСправкиОНеполученииПособияОтОтца, "ДФ=yyyy-MM-dd");
		КонецЕсли;
		Если ЗначениеЗаполнено(СтруктураДанных.НомерСправкиОНеполученииПособияОтМатери) И ЗначениеЗаполнено(СтруктураДанных.ДатаСправкиОНеполученииПособияОтМатери) Тогда
			ROW.REF_NPAY_MOTHER_NO = СтруктураДанных.НомерСправкиОНеполученииПособияОтМатери;
			ROW.REF_NPAY_MOTHER_DT = Формат(СтруктураДанных.ДатаСправкиОНеполученииПособияОтМатери, "ДФ=yyyy-MM-dd");
		КонецЕсли;
		Если ЗначениеЗаполнено(СтруктураДанных.НомерСправкиПоДругимМестамРаботы) И ЗначениеЗаполнено(СтруктураДанных.ДатаСправкиПоДругимМестамРаботы) Тогда
			ROW.REF_NPAY_WORK_NO = СтруктураДанных.НомерСправкиПоДругимМестамРаботы;
			ROW.REF_NPAY_WORK_DT = Формат(СтруктураДанных.ДатаСправкиПоДругимМестамРаботы, "ДФ=yyyy-MM-dd");
		КонецЕсли;
		Если ЗначениеЗаполнено(СтруктураДанных.ДатаСмертиРебенка) Тогда
			ROW.CERT_DT_DATE = Формат(СтруктураДанных.ДатаСмертиРебенка, "ДФ=yyyy-MM-dd");
		КонецЕсли;
		Если ЗначениеЗаполнено(СтруктураДанных.ВыплатаЗаСчетФедеральногоБюджета) 
			И НЕ СтруктураДанных.ВыплатаЗаСчетФедеральногоБюджета = Перечисления.ОснованияФинансированияПособияФедеральнымБюджетом.ЗачетНестраховыхПериодов 
			И ЗначениеЗаполнено(СтруктураДанных.ПроживаниеРаботаВЛьготнойЗоне)
			И НЕ СтруктураДанных.ПроживаниеРаботаВЛьготнойЗоне = Перечисления.ОтношениеКОсобойЗоне.Нет Тогда
			
			Если СтруктураДанных.ПроживаниеРаботаВЛьготнойЗоне = Перечисления.ОтношениеКОсобойЗоне.Проживает Тогда
				ROW.LIVE_COND_FLAG 	= 1; 
			ИначеЕсли СтруктураДанных.ПроживаниеРаботаВЛьготнойЗоне = Перечисления.ОтношениеКОсобойЗоне.Работает Тогда	
				ROW.LIVE_COND_FLAG 	= 2; 
			КонецЕсли;
			
			Если СтруктураДанных.СтатусЛьготнойЗоны = Перечисления.ВидыОсобойЗоныПроживанияРаботы.ЗонаСПравомНаОтселение Тогда
				ROW.LIVE_COND 		= 1;
			ИначеЕсли СтруктураДанных.СтатусЛьготнойЗоны = Перечисления.ВидыОсобойЗоныПроживанияРаботы.ЗонаОтселения Тогда	
				ROW.LIVE_COND 		= 3;
			ИначеЕсли СтруктураДанных.СтатусЛьготнойЗоны = Перечисления.ВидыОсобойЗоныПроживанияРаботы.ЗонаСЛьготнымСоциальноЭкономическимСтатусом Тогда 
				ROW.LIVE_COND 		= 2;
			ИначеЕсли СтруктураДанных.СтатусЛьготнойЗоны = Перечисления.ВидыОсобойЗоныПроживанияРаботы.ЗонаЗагрязненияПриАварииПОМаяк Тогда 
				ROW.LIVE_COND 		= 4;
			КонецЕсли;
			
			Если СтруктураДанных.ВыплатаЗаСчетФедеральногоБюджета = Перечисления.ОснованияФинансированияПособияФедеральнымБюджетом.Чернобыль Тогда
				ROW.CODE_NUCLEAR = 1;
			ИначеЕсли СтруктураДанных.ВыплатаЗаСчетФедеральногоБюджета = Перечисления.ОснованияФинансированияПособияФедеральнымБюджетом.Семипалатинск Тогда
				ROW.CODE_NUCLEAR = 2;
			ИначеЕсли СтруктураДанных.ВыплатаЗаСчетФедеральногоБюджета = Перечисления.ОснованияФинансированияПособияФедеральнымБюджетом.Маяк Тогда
				ROW.CODE_NUCLEAR = 3;
			ИначеЕсли СтруктураДанных.ВыплатаЗаСчетФедеральногоБюджета = Перечисления.ОснованияФинансированияПособияФедеральнымБюджетом.ПодразделенияОсобогоРиска Тогда
				ROW.CODE_NUCLEAR = 4;
			КонецЕсли;
			
		КонецЕсли;
		
	КонецЕсли;
	
	//<<-- //НАЧ #  
	//Если Не СтруктураДанных.ЭтоЭЛН Или СтруктураДанных.ЭЛНКарантинПоКоронавирусу
	//	Или СтрНачинаетсяС(СтруктураДанных.НомерВходящегоДокумента, "9990") Тогда 
	//-->> //КОН #
		
		Если СтруктураДанных.ВидВыплаты = "1" Или СтруктураДанных.ВидВыплаты = "2" Или СтруктураДанных.ВидВыплаты = "6" Тогда
			Если ЗначениеЗаполнено(СтруктураДанных.НомерПервичногоБольничного) Тогда
				ROW.PREV_LN_CODE = СтруктураДанных.НомерПервичногоБольничного;
				ROW.PRIMARY_FLAG = 0;
			Иначе
				ROW.PRIMARY_FLAG = 1;
			КонецЕсли;
			ROW.DUPLICATE_FLAG = Формат(СтруктураДанных.ЯвляетсяДубликатом, "БЛ=0; БИ=1");
			ROW.LN_DATE = Формат(СтруктураДанных.ДатаВыдачиБольничного, "ДФ=yyyy-MM-dd");
			ROW.LPU_NAME = СтруктураДанных.НаименованиеМедицинскойОрганизации;
			ROW.LPU_OGRN = СтруктураДанных.ОГРНМедицинскойОрганизации;
			ROW.REASON1 = СтруктураДанных.КодПричиныНетрудоспособности;
			Если СтруктураДанных.Совместительство Тогда
				ROW.PARENT_CODE = СтруктураДанных.НомерЛисткаПоОсновномуМестуРаботы;
			КонецЕсли;
			Если ЗначениеЗаполнено(СтруктураДанных.ПериодНахожденияВСтационареСРебенкомС) Или ЗначениеЗаполнено(СтруктураДанных.ПериодНахожденияВСтационареСРебенкомПо) Тогда
				ROW.HOSPITAL_DT1 = Формат(СтруктураДанных.ПериодНахожденияВСтационареСРебенкомС, "ДФ=yyyy-MM-dd");
				ROW.HOSPITAL_DT2 = Формат(СтруктураДанных.ПериодНахожденияВСтационареСРебенкомПо, "ДФ=yyyy-MM-dd");
			КонецЕсли;
			Если ЗначениеЗаполнено(СтруктураДанных.КодНарушенияРежима) И ЗначениеЗаполнено(СтруктураДанных.ДатаНарушенияРежима) Тогда
				ROW.HOSPITAL_BREACH_CODE = СтруктураДанных.КодНарушенияРежима;
				ROW.HOSPITAL_BREACH_DT   = Формат(СтруктураДанных.ДатаНарушенияРежима, "ДФ=yyyy-MM-dd");
			КонецЕсли;
			Если ЗначениеЗаполнено(СтруктураДанных.НовыйСтатусНетрудоспособного) Тогда
				ROW.MSE_RESULT = СтруктураДанных.НовыйСтатусНетрудоспособного;
				Если СтруктураДанных.НовыйСтатусНетрудоспособного = "31" Тогда
					ROW.NEXT_LN_CODE = СтруктураДанных.НомерЛисткаПродолжения;
				КонецЕсли;
			КонецЕсли;
			Если ЗначениеЗаполнено(СтруктураДанных.ОсвобождениеС1) Или ЗначениеЗаполнено(СтруктураДанных.ОсвобождениеПо1) Тогда
				ROW.TREAT1_DOCTOR_ROLE  = СтруктураДанных.ДолжностьВрача1;
				ROW.TREAT1_DOCTOR       = СтруктураДанных.ФИОВрача1;
				Если ЗначениеЗаполнено(СтруктураДанных.ДолжностьВрачаПредседателяВК1) Тогда
					ROW.TREAT1_DOCTOR2_ROLE = "ПРЕД ВК";
				КонецЕсли;
			КонецЕсли;
			Если ЗначениеЗаполнено(СтруктураДанных.ОсвобождениеС2) Или ЗначениеЗаполнено(СтруктураДанных.ОсвобождениеПо2) Тогда
				ROW.TREAT2_DT1          = Формат(СтруктураДанных.ОсвобождениеС2, "ДФ=yyyy-MM-dd");
				ROW.TREAT2_DT2          = Формат(СтруктураДанных.ОсвобождениеПо2, "ДФ=yyyy-MM-dd");
				ROW.TREAT2_DOCTOR_ROLE  = СтруктураДанных.ДолжностьВрача2;
				ROW.TREAT2_DOCTOR       = СтруктураДанных.ФИОВрача2;
				Если ЗначениеЗаполнено(СтруктураДанных.ДолжностьВрачаПредседателяВК2) Тогда
					ROW.TREAT2_DOCTOR2_ROLE = "ПРЕД ВК";
				КонецЕсли;
			КонецЕсли;
			Если ЗначениеЗаполнено(СтруктураДанных.ОсвобождениеС3) Или ЗначениеЗаполнено(СтруктураДанных.ОсвобождениеПо3) Тогда
				ROW.TREAT3_DT1          = Формат(СтруктураДанных.ОсвобождениеС3, "ДФ=yyyy-MM-dd");
				ROW.TREAT3_DT2          = Формат(СтруктураДанных.ОсвобождениеПо3, "ДФ=yyyy-MM-dd");
				ROW.TREAT3_DOCTOR_ROLE  = СтруктураДанных.ДолжностьВрача3;
				ROW.TREAT3_DOCTOR       = СтруктураДанных.ФИОВрача3;
				Если ЗначениеЗаполнено(СтруктураДанных.ДолжностьВрачаПредседателяВК3) Тогда
					ROW.TREAT3_DOCTOR2_ROLE = "ПРЕД ВК";
				КонецЕсли;
			КонецЕсли;
			ROW.OTHER_STATE_DT 			= Формат(СтруктураДанных.ДатаНовыйСтатусНетрудоспособного, "ДФ=yyyy-MM-dd");
			ROW.RETURN_DATE_LPU 		= Формат(СтруктураДанных.ДатаВыходаНаРаботу, "ДФ=yyyy-MM-dd");
		КонецЕсли;
		
		Если СтруктураДанных.ВидВыплаты = "1" Или СтруктураДанных.ВидВыплаты = "2" Тогда
			ROW.DATE1 = Формат(СтруктураДанных.ДатаИзмененияКодаПричиныНетрудоспособности, "ДФ=yyyy-MM-dd");
			ROW.DATE2 = Формат(СтруктураДанных.ДатаОкончанияПутевки, "ДФ=yyyy-MM-dd");
			Если ЗначениеЗаполнено(СтруктураДанных.УходЗаРодственникомФИО1) Тогда
				ROW.SERV1_AGE 			= СтруктураДанных.УходЗаРодственникомЛет1;
				ROW.SERV1_MM 			= СтруктураДанных.УходЗаРодственникомМесяцев1;
				ROW.SERV1_RELATION_CODE = СтруктураДанных.УходЗаРодственникомРодственнаяСвязь1;
				ROW.SERV1_FIO 			= СтруктураДанных.УходЗаРодственникомФИО1;
			КонецЕсли;
			Если ЗначениеЗаполнено(СтруктураДанных.УходЗаРодственникомФИО2) Тогда
				ROW.SERV2_AGE 			= СтруктураДанных.УходЗаРодственникомЛет2;
				ROW.SERV2_MM 			= СтруктураДанных.УходЗаРодственникомМесяцев2;
				ROW.SERV2_RELATION_CODE = СтруктураДанных.УходЗаРодственникомРодственнаяСвязь2;
				ROW.SERV2_FIO 			= СтруктураДанных.УходЗаРодственникомФИО2;
			КонецЕсли;
			Если ЗначениеЗаполнено(СтруктураДанных.ДатаИзмененияКодаПричиныНетрудоспособности)
				И (СтруктураДанных.ДополнительныйКодПричиныНетрудоспособности = "017"
					Или СтруктураДанных.ДополнительныйКодПричиныНетрудоспособности = "018"
					Или СтруктураДанных.ДополнительныйКодПричиныНетрудоспособности = "019") Тогда
				ROW.VOUCHER_OGRN = СтруктураДанных.ОГРН_Санатория;
			КонецЕсли;
		КонецЕсли;
		
	//<<-- //НАЧ #
	//КонецЕсли;
	//-->> //КОН #	
	
КонецПроцедуры

Показать
Olga_Mil; Hla; +2 Ответить
22. dimmkan 11.03.21 12:09 Сейчас в теме
(19)
Если Не СтруктураДанных.Перерасчет Тогда
ROW.TYPE_INFO = "0";
Иначе
ROW.TYPE_INFO = "1";
ROW.RECALC_REASON_CODE = Число("0"+СтруктураДанных.КодПричиныПерерасчета);
КонецЕсли;

Если СтруктураДанных.ВидВыплаты = "1" Тогда

КонецЕсли;

ROW.DOC_TYPE = СтруктураДанных.ВидВыплаты;
ROW.DOC_DT1 = СтруктураДанных.ДатаПредставленияПакетаДокументов;
ROW.SNILS = СтрЗаменить(СтрЗаменить(СтруктураДанных.СтраховойНомерПФР, "-","")," ","");
ROW.INN_PERSON = СтруктураДанных.ИНН;
ROW.SURNAME = СтруктураДанных.Фамилия;
ROW.NAME = СтруктураДанных.Имя;
ROW.PATRONIMIC = СтруктураДанных.Отчество;

ЗаполнитьСтатусНалогоплательщикаВСтрокеРеестра(ROW, СтруктураДанных);

ROW.RESIDENT_CODE = СтруктураДанных.КодСтраны;
ROW.BIRTHDAY = СтруктураДанных.ДатаРождения;
ROW.GENDER = Формат(СтруктураДанных.Пол = Перечисления.ПолФизическогоЛица.Женский, "БЛ=0; БИ=1");

Если ЗначениеЗаполнено(СтруктураДанных.КодМВДДокументаНаПроживание)
И ЗначениеЗаполнено(СтруктураДанных.СерияДокументаНаПроживание + " " + СтруктураДанных.НомерДокументаНаПроживание)
И ЗначениеЗаполнено(СтруктураДанных.ДатаВыдачиДокументаНаПроживание)
И ЗначениеЗаполнено(СтруктураДанных.КемВыданДокументНаПроживание)
И ЗначениеЗаполнено(СтруктураДанных.Гражданство)
И СтруктураДанных.Гражданство <> ОбщегоНазначения.ПредопределенныйЭлемент("Справочник.СтраныМира.Россия") Тогда

ROW.ID_TYPE = СтруктураДанных.КодМВДДокументаНаПроживание;
ROW.ID_NO = СтруктураДанных.СерияДокументаНаПроживание + " " + СтруктураДанных.НомерДокументаНаПроживание;
ROW.ID_DT = СтруктураДанных.ДатаВыдачиДокументаНаПроживание;
ROW.ID_DEPT = СокрЛП(СтруктураДанных.КемВыданДокументНаПроживание);

Иначе

ROW.ID_TYPE = СтруктураДанных.ВидУдостоверенияЛичности;
ROW.ID_NO = СтруктураДанных.СерияДокумента + " " + СтруктураДанных.НомерДокумента;
ROW.ID_DT = СтруктураДанных.ДатаВыдачиДокумента;
ROW.ID_DEPT = СокрЛП(СтруктураДанных.КемВыданДокумент);

КонецЕсли;

ROW.OWNER_FLAG = 1;
ROW.EMPL_FLAG = Формат(СтруктураДанных.Совместительство, "БЛ=1; БИ=0");

// Приказ страхователя:
// 1 - о досрочном выходе на работу;
// 2 - о прекращении трудовых отношений.
Если СтруктураДанных.ДосрочноеПрекращениеОтпускаПоУходуТипПриказа = Перечисления.СостоянияСотрудника.Работа Тогда
HOLID_TYPE = "1";
ИначеЕсли СтруктураДанных.ДосрочноеПрекращениеОтпускаПоУходуТипПриказа = Перечисления.СостоянияСотрудника.Увольнение Тогда
HOLID_TYPE = "2";
Иначе
HOLID_TYPE = Неопределено;
КонецЕсли;
Если HOLID_TYPE <> Неопределено Тогда
ROW.HOLID_TYPE = HOLID_TYPE;
ROW.HOLID_NO = СтруктураДанных.ДосрочноеПрекращениеОтпускаПоУходуНомерПриказа;
ROW.HOLID_DT = СтруктураДанных.ДосрочноеПрекращениеОтпускаПоУходуДатаПриказа;
ROW.HOLID_DT_EX = СтруктураДанных.ДосрочноеПрекращениеОтпускаПоУходуДатаПрекращенияОплаты;
КонецЕсли;

// Извещение о представлении недостающих сведений в ФСС;
// Решение об отказе в назначении пособия:
Если СтруктураДанных.ИзвещениеИзФССИспользование Тогда
ROW.RESP_NO = СтруктураДанных.ИзвещениеИзФССНомер;
ROW.RESP_DT = СтруктураДанных.ИзвещениеИзФССДата;
КонецЕсли;

Если СтруктураДанных.СпособВыплатыПособия = Перечисления.СпособыВыплатыПособия.ПочтовымПереводом Тогда

ROW.PAYMENT_TYPE = "0"; // Способ выплаты: почтовый перевод.

ОписаниеАдреса = СтруктураАдреса(СтруктураДанных.АдресПолучателяФактический);

ROW.POST_INDEX = ОписаниеАдреса.Индекс;
ROW.ADDR_A1 = ОписаниеАдреса.Регион;
ROW.ADDR_A2 = ОписаниеАдреса.Район;
ROW.ADDR_A3 = ОписаниеАдреса.Город;
ROW.ADDR_A4 = ОписаниеАдреса.НаселенныйПункт;
ROW.ADDR_PLAN = ОписаниеАдреса.Территория;
ROW.ADDR_A5 = ОписаниеАдреса.Улица;
ROW.ADDR_HOUSE = ОписаниеАдреса.Дом;
ROW.ADDR_BUILDING = ОписаниеАдреса.Корпус;
ROW.ADDR_FLAT = ОписаниеАдреса.Квартира;

ROW.ADDR_KLADR = СтруктураДанных.АдресПолучателяФактическийКодКЛАДР;
ROW.ADDR_GUID = СтруктураДанных.АдресПолучателяФактическийИдентификаторФИАС;

ИначеЕсли СтруктураДанных.СпособВыплатыПособия = Перечисления.СпособыВыплатыПособия.ЧерезБанк Тогда

ROW.PAYMENT_TYPE = "1"; // Способ выплаты: банковский счет (расчетный счет).
ROW.ACCOUNT_BIC = СтруктураДанных.БИКБанка;
ROW.ACCOUNT_NAME = СтруктураДанных.НаименованиеБанка;
ROW.ACCOUNT = ОставитьТолькоЦифрыВСтроке(СтруктураДанных.НомерЛицевогоСчета);

ИначеЕсли СтруктураДанных.СпособВыплатыПособия = Перечисления.СпособыВыплатыПособия.НаКартуМИР Тогда

ROW.PAYMENT_TYPE = "2"; // Способ выплаты: банковский счет (карта МИР).
ROW.PAYCARD_NUM = БанковскиеКарты.ПолныйНомерКарты(СтруктураДанных.КартаМИР);

КонецЕсли;

Если ЗначениеЗаполнено(СтруктураДанных.АдресПолучателяРегистрации) Тогда
Если ROW.RESIDENT_FLAG = 1 Тогда

ОписаниеАдреса = СтруктураАдреса(СтруктураДанных.АдресПолучателяРегистрации);

ROW.POST_INDEX2 = ОписаниеАдреса.Индекс;
ROW.ADDR2_A1 = ОписаниеАдреса.Регион;
ROW.ADDR2_A2 = ОписаниеАдреса.Район;
ROW.ADDR2_A3 = ОписаниеАдреса.Город;
ROW.ADDR2_A4 = ОписаниеАдреса.НаселенныйПункт;
ROW.ADDR2_PLAN = ОписаниеАдреса.Территория;
ROW.ADDR2_A5 = ОписаниеАдреса.Улица;
ROW.ADDR2_HOUSE = ОписаниеАдреса.Дом;
ROW.ADDR2_BUILDING = ОписаниеАдреса.Корпус;
ROW.ADDR2_FLAT = ОписаниеАдреса.Квартира;

ROW.ADDR2_KLADR = СтруктураДанных.АдресПолучателяРегистрацииКодКЛАДР;
ROW.ADDR2_GUID = СтруктураДанных.АдресПолучателяРегистрацииИдентификаторФИАС;

Иначе

ТипАдреса = Справочники.ВидыКонтактнойИнформации.АдресПоПропискеФизическиеЛица;
ROW.ADDR2 = УправлениеКонтактнойИнформацией.ПредставлениеКонтактнойИнформации(СтруктураДанных.АдресПолучателяРегистрации, ТипАдреса);

КонецЕсли;
КонецЕсли;

Если СтруктураДанных.РайонныйКоэффициент >= 1.10 И СтруктураДанных.РайонныйКоэффициент 0 Или РазностьСтажей.РазностьМесяцев <> 0 Тогда
ROW.INSUR_YY = СтруктураДанных.СтажРасширенныйЛет;
ROW.INSUR_MM = СтруктураДанных.СтажРасширенныйМесяцев;
ROW.NOT_INSUR_YY = РазностьСтажей.РазностьЛет;
ROW.NOT_INSUR_MM = РазностьСтажей.РазностьМесяцев;
Иначе
ROW.INSUR_YY = СтруктураДанных.СтажЛет;
ROW.INSUR_MM = СтруктураДанных.СтажМесяцев;
КонецЕсли;

ROW.LN_CODE = СтруктураДанных.НомерВходящегоДокумента;
ROW.LN_TYPE = Формат(СтруктураДанных.ЭтоЭЛН, "БЛ=0; БИ=1");

ROW.LPU_ADDRESS = СтруктураДанных.АдресМедицинскойОрганизации;

ROW.REASON2 = СтруктураДанных.ДополнительныйКодПричиныНетрудоспособности;
ROW.REASON3 = СтруктураДанных.ВторойКодПричиныНетрудоспособности;
ROW.VOUCHER_NO = СтруктураДанных.НомерПутевки;

Если ЗначениеЗаполнено(СтруктураДанных.УходЗаРодственникомФИО1) Тогда
ROW.SERV1_DAYS = СтруктураДанных.УходЗаРодственникомИспользованоДней1;
КонецЕсли;
Если ЗначениеЗаполнено(СтруктураДанных.УходЗаРодственникомФИО2) Тогда
ROW.SERV2_DAYS = СтруктураДанных.УходЗаРодственникомИспользованоДней2;
КонецЕсли;
ROW.MSE_DT1 = Формат(СтруктураДанных.ДатаНаправленияВБюроМСЭ, "ДФ=yyyy-MM-dd");
ROW.MSE_DT2 = Формат(СтруктураДанных.ДатаРегистрацииДокументовМСЭ, "ДФ=yyyy-MM-dd");
ROW.MSE_DT3 = Формат(СтруктураДанных.ДатаОсвидетельствованияМСЭ, "ДФ=yyyy-MM-dd");
Если ЗначениеЗаполнено(СтруктураДанных.ГруппаИнвалидности) Тогда
ROW.MSE_INVALID_GROUP = СтруктураДанных.ГруппаИнвалидности;
КонецЕсли;
Если ЗначениеЗаполнено(СтруктураДанных.ДнейБолезниИнвалида) Тогда
ROW.MSE_INVALID_DAYS = СтруктураДанных.ДнейБолезниИнвалида;
КонецЕсли;

Если ЗначениеЗаполнено(СтруктураДанных.ОсвобождениеС1) Или ЗначениеЗаполнено(СтруктураДанных.ОсвобождениеПо1) Тогда
ROW.TREAT1_DT1 = Формат(СтруктураДанных.ОсвобождениеС1, "ДФ=yyyy-MM-dd");
ROW.TREAT1_DT2 = Формат(СтруктураДанных.ОсвобождениеПо1, "ДФ=yyyy-MM-dd");
ROW.TREAT1_DOC_ID = СтруктураДанных.ИдентификационныйНомерВрача1;
ROW.TREAT1_CHAIRMAN_VK = СтруктураДанных.ФИОВрачаПредседателяВК1;
ROW.TREAT1_DOC2_ID = СтруктураДанных.ИдентификационныйНомерВрачаПредседателяВК1;
КонецЕсли;
Если ЗначениеЗаполнено(СтруктураДанных.ОсвобождениеС2) Или ЗначениеЗаполнено(СтруктураДанных.ОсвобождениеПо2) Тогда
ROW.TREAT2_DOC_ID = СтруктураДанных.ИдентификационныйНомерВрача2;
ROW.TREAT2_CHAIRMAN_VK = СтруктураДанных.ФИОВрачаПредседателяВК2;
ROW.TREAT2_DOC2_ID = СтруктураДанных.ИдентификационныйНомерВрачаПредседателяВК2;
КонецЕсли;
Если ЗначениеЗаполнено(СтруктураДанных.ОсвобождениеС3) Или ЗначениеЗаполнено(СтруктураДанных.ОсвобождениеПо3) Тогда
ROW.TREAT3_DOC_ID = СтруктураДанных.ИдентификационныйНомерВрача3;
ROW.TREAT3_CHAIRMAN_VK = СтруктураДанных.ФИОВрачаПредседателяВК3;
ROW.TREAT3_DOC2_ID = СтруктураДанных.ИдентификационныйНомерВрачаПредседателяВК3;
КонецЕсли;
ROW.CALC_CONDITION1 = СтруктураДанных.УсловияИсчисленияКод1;
ROW.CALC_CONDITION2 = СтруктураДанных.УсловияИсчисленияКод2;
ROW.CALC_CONDITION3 = СтруктураДанных.УсловияИсчисленияКод3;
Если СтруктураДанных.УсловияИсчисленияКод1 = "43" Или СтруктураДанных.УсловияИсчисленияКод2 = "43" Или СтруктураДанных.УсловияИсчисленияКод3 = "43" Тогда
Если СтруктураДанных.ВыплатаЗаСчетФедеральногоБюджета = Перечисления.ОснованияФинансированияПособияФедеральнымБюджетом.Чернобыль Тогда
ROW.CODE_NUCLEAR = 1;
ИначеЕсли СтруктураДанных.ВыплатаЗаСчетФедеральногоБюджета = Перечисления.ОснованияФинансированияПособияФедеральнымБюджетом.Семипалатинск Тогда
ROW.CODE_NUCLEAR = 2;
ИначеЕсли СтруктураДанных.ВыплатаЗаСчетФедеральногоБюджета = Перечисления.ОснованияФинансированияПособияФедеральнымБюджетом.Маяк Тогда
ROW.CODE_NUCLEAR = 3;
ИначеЕсли СтруктураДанных.ВыплатаЗаСчетФедеральногоБюджета = Перечисления.ОснованияФинансированияПособияФедеральнымБюджетом.ПодразделенияОсобогоРиска Тогда
ROW.CODE_NUCLEAR = 4;
КонецЕсли;
КонецЕсли;
Если ЗначениеЗаполнено(СтруктураДанных.ДатаАктаФормыН1) Тогда
ROW.FORM1_DT = Формат(СтруктураДанных.ДатаАктаФормыН1, "ДФ=yyyy-MM-dd");
КонецЕсли;
Если ЗначениеЗаполнено(СтруктураДанных.ДатаНачалаРаботы) Тогда
ROW.RETURN_DATE_EMPL = Формат(СтруктураДанных.ДатаНачалаРаботы, "ДФ=yyyy-MM-dd");
КонецЕсли;
Если ЗначениеЗаполнено(СтруктураДанных.СрочныйДоговорС) И ЗначениеЗаполнено(СтруктураДанных.СрочныйДоговорПо) Тогда
ROW.WORK_CONTRACT_START_DT = Формат(СтруктураДанных.СрочныйДоговорС, "ДФ=yyyy-MM-dd");
ROW.WORK_CONTRACT_FINISH_DT = Формат(СтруктураДанных.СрочныйДоговорПо, "ДФ=yyyy-MM-dd");
КонецЕсли;
ROW.FSS_PAYMENT_FLAG = ?(ЗначениеЗаполнено(СтруктураДанных.ДатаНачалаОплаты), 1, 0);
Если ЗначениеЗаполнено(СтруктураДанных.ДатаНачалаОплаты) Тогда
ROW.DT1 = Формат(СтруктураДанных.ДатаНачалаОплаты, "ДФ=yyyy-MM-dd");
ROW.DT2 = Формат(СтруктураДанных.ДатаОкончанияОплаты, "ДФ=yyyy-MM-dd");
КонецЕсли;
Если ЗначениеЗаполнено(СтруктураДанных.СуммаПособияРаботодателя) Тогда
ROW.EMPL_PAYMENT = СтруктураДанных.СуммаПособияРаботодателя;
КонецЕсли;
Если ЗначениеЗаполнено(СтруктураДанных.СуммаПособияФСС) Тогда
ROW.FSS_PAYMENT = СтруктураДанных.СуммаПособияФСС;
КонецЕсли;
Если ЗначениеЗаполнено(СтруктураДанных.СуммаПособияВсего) Тогда
ROW.PAYMENT = СтруктураДанных.СуммаПособияВсего;
КонецЕсли;
КонецЕсли;

Если СтруктураДанных.ВидВыплаты = "1" Или СтруктураДанных.ВидВыплаты = "2" Или СтруктураДанных.ВидВыплаты = "5" Тогда
ROW.BASE_AVG_DAILY_SAL = СтруктураДанных.СреднийЗаработокЗаРасчетныйПериод;
Если СтруктураДанных.ПорядокРасчетаСреднегоЗаработка = Перечисления.СпособыРасчетаСреднегоЗаработкаДляОплатыПособия.СреднийЗаработок Тогда
ROW.YEAR1 = СтруктураДанных.ПервыйГодРасчета;
ROW.YEAR2 = СтруктураДанных.ВторойГодРасчета;

Если СтруктураДанных.ЗамененыКалендарныеГодыРасчетаСреднегоЗаработка Тогда
ROW.YEAR_CHANGE_FLAG = 1;
ROW.YEAR1_OLD = СтруктураДанных.ЗамененныйПервыйГодРасчета;
ROW.YEAR2_OLD = СтруктураДанных.ЗамененныйВторойГодРасчета;
Иначе
ROW.YEAR_CHANGE_FLAG = 0;
КонецЕсли;

ROW.BASE_CALC_DAYS = СтруктураДанных.КалендарныхДнейРасчетногоПериода;
ROW.BASE_SUM1 = СтруктураДанных.ЗаработокПервыйГодРасчета;
ROW.BASE_SUM2 = СтруктураДанных.ЗаработокВторойГодРасчета;
ROW.BASE_AVG_SAL = СреднийЗаработокЗаДваКалендарныхГода(СтруктураДанных);
КонецЕсли;
Если СтруктураДанных.ДоляВремени > 0 И СтруктураДанных.ДоляВремени > //КОН #

Если СтруктураДанных.ВидВыплаты = "1" Или СтруктураДанных.ВидВыплаты = "2" Или СтруктураДанных.ВидВыплаты = "6" Тогда
Если ЗначениеЗаполнено(СтруктураДанных.НомерПервичногоБольничного) Тогда
ROW.PREV_LN_CODE = СтруктураДанных.НомерПервичногоБольничного;
ROW.PRIMARY_FLAG = 0;
Иначе
ROW.PRIMARY_FLAG = 1;
КонецЕсли;
ROW.DUPLICATE_FLAG = Формат(СтруктураДанных.ЯвляетсяДубликатом, "БЛ=0; БИ=1");
ROW.LN_DATE = Формат(СтруктураДанных.ДатаВыдачиБольничного, "ДФ=yyyy-MM-dd");
ROW.LPU_NAME = СтруктураДанных.НаименованиеМедицинскойОрганизации;
ROW.LPU_OGRN = СтруктураДанных.ОГРНМедицинскойОрганизации;
ROW.REASON1 = СтруктураДанных.КодПричиныНетрудоспособности;
Если СтруктураДанных.Совместительство Тогда
ROW.PARENT_CODE = СтруктураДанных.НомерЛисткаПоОсновномуМестуРаботы;
КонецЕсли;
Если ЗначениеЗаполнено(СтруктураДанных.ПериодНахожденияВСтационареСРебенкомС) Или ЗначениеЗаполнено(СтруктураДанных.ПериодНахожденияВСтационареСРебенкомПо) Тогда
ROW.HOSPITAL_DT1 = Формат(СтруктураДанных.ПериодНахожденияВСтационареСРебенкомС, "ДФ=yyyy-MM-dd");
ROW.HOSPITAL_DT2 = Формат(СтруктураДанных.ПериодНахожденияВСтационареСРебенкомПо, "ДФ=yyyy-MM-dd");
КонецЕсли;
Если ЗначениеЗаполнено(СтруктураДанных.КодНарушенияРежима) И ЗначениеЗаполнено(СтруктураДанных.ДатаНарушенияРежима) Тогда
ROW.HOSPITAL_BREACH_CODE = СтруктураДанных.КодНарушенияРежима;
ROW.HOSPITAL_BREACH_DT = Формат(СтруктураДанных.ДатаНарушенияРежима, "ДФ=yyyy-MM-dd");
КонецЕсли;
Если ЗначениеЗаполнено(СтруктураДанных.НовыйСтатусНетрудоспособного) Тогда
ROW.MSE_RESULT = СтруктураДанных.НовыйСтатусНетрудоспособного;
Если СтруктураДанных.НовыйСтатусНетрудоспособного = "31" Тогда
ROW.NEXT_LN_CODE = СтруктураДанных.НомерЛисткаПродолжения;
КонецЕсли;
КонецЕсли;
Если ЗначениеЗаполнено(СтруктураДанных.ОсвобождениеС1) Или ЗначениеЗаполнено(СтруктураДанных.ОсвобождениеПо1) Тогда
ROW.TREAT1_DOCTOR_ROLE = СтруктураДанных.ДолжностьВрача1;
ROW.TREAT1_DOCTOR = СтруктураДанных.ФИОВрача1;
Если ЗначениеЗаполнено(СтруктураДанных.ДолжностьВрачаПредседателяВК1) Тогда
ROW.TREAT1_DOCTOR2_ROLE = "ПРЕД ВК";
КонецЕсли;
КонецЕсли;
Если ЗначениеЗаполнено(СтруктураДанных.ОсвобождениеС2) Или ЗначениеЗаполнено(СтруктураДанных.ОсвобождениеПо2) Тогда
ROW.TREAT2_DT1 = Формат(СтруктураДанных.ОсвобождениеС2, "ДФ=yyyy-MM-dd");
ROW.TREAT2_DT2 = Формат(СтруктураДанных.ОсвобождениеПо2, "ДФ=yyyy-MM-dd");
ROW.TREAT2_DOCTOR_ROLE = СтруктураДанных.ДолжностьВрача2;
ROW.TREAT2_DOCTOR = СтруктураДанных.ФИОВрача2;
Если ЗначениеЗаполнено(СтруктураДанных.ДолжностьВрачаПредседателяВК2) Тогда
ROW.TREAT2_DOCTOR2_ROLE = "ПРЕД ВК";
КонецЕсли;
КонецЕсли;
Если ЗначениеЗаполнено(СтруктураДанных.ОсвобождениеС3) Или ЗначениеЗаполнено(СтруктураДанных.ОсвобождениеПо3) Тогда
ROW.TREAT3_DT1 = Формат(СтруктураДанных.ОсвобождениеС3, "ДФ=yyyy-MM-dd");
ROW.TREAT3_DT2 = Формат(СтруктураДанных.ОсвобождениеПо3, "ДФ=yyyy-MM-dd");
ROW.TREAT3_DOCTOR_ROLE = СтруктураДанных.ДолжностьВрача3;
ROW.TREAT3_DOCTOR = СтруктураДанных.ФИОВрача3;
Если ЗначениеЗаполнено(СтруктураДанных.ДолжностьВрачаПредседателяВК3) Тогда
ROW.TREAT3_DOCTOR2_ROLE = "ПРЕД ВК";
КонецЕсли;
КонецЕсли;
ROW.OTHER_STATE_DT = Формат(СтруктураДанных.ДатаНовыйСтатусНетрудоспособного, "ДФ=yyyy-MM-dd");
ROW.RETURN_DATE_LPU = Формат(СтруктураДанных.ДатаВыходаНаРаботу, "ДФ=yyyy-MM-dd");
КонецЕсли;

Если СтруктураДанных.ВидВыплаты = "1" Или СтруктураДанных.ВидВыплаты = "2" Тогда
ROW.DATE1 = Формат(СтруктураДанных.ДатаИзмененияКодаПричиныНетрудоспособности, "ДФ=yyyy-MM-dd");
ROW.DATE2 = Формат(СтруктураДанных.ДатаОкончанияПутевки, "ДФ=yyyy-MM-dd");
Если ЗначениеЗаполнено(СтруктураДанных.УходЗаРодственникомФИО1) Тогда
ROW.SERV1_AGE = СтруктураДанных.УходЗаРодственникомЛет1;
ROW.SERV1_MM = СтруктураДанных.УходЗаРодственникомМесяцев1;
ROW.SERV1_RELATION_CODE = СтруктураДанных.УходЗаРодственникомРодственнаяСвязь1;
ROW.SERV1_FIO = СтруктураДанных.УходЗаРодственникомФИО1;
КонецЕсли;
Если ЗначениеЗаполнено(СтруктураДанных.УходЗаРодственникомФИО2) Тогда
ROW.SERV2_AGE = СтруктураДанных.УходЗаРодственникомЛет2;
ROW.SERV2_MM = СтруктураДанных.УходЗаРодственникомМесяцев2;
ROW.SERV2_RELATION_CODE = СтруктураДанных.УходЗаРодственникомРодственнаяСвязь2;
ROW.SERV2_FIO = СтруктураДанных.УходЗаРодственникомФИО2;
КонецЕсли;
Если ЗначениеЗаполнено(СтруктураДанных.ДатаИзмененияКодаПричиныНетрудоспособности)
И (СтруктураДанных.ДополнительныйКодПричиныНетрудоспособности = "017"
Или СтруктураДанных.ДополнительныйКодПричиныНетрудоспособности = "018"
Или СтруктураДанных.ДополнительныйКодПричиныНетрудоспособности = "019") Тогда
ROW.VOUCHER_OGRN = СтруктураДанных.ОГРН_Санатория;
КонецЕсли;
КонецЕсли;

//> //КОН #
Показать


Дай бог тебе здоровья, добрый человек.
(19)
Olga_Mil; +1 Ответить
20. tank68 17 05.03.21 14:22 Сейчас в теме
(18)Как будешь править либо в расширении и процедура вместо, либо в основной конфигурации нужно закомментировать часть кода, в котором определено что данные не будут выгружаться по ЭЛН.
Нам со СБИС это помогло, они такой файл принимают корректно.
21. user633533_encantado 10 09.03.21 15:59 Сейчас в теме
Делал у себя такую же доработку, только сделал с возможностью выбора формата для каждого пользователя.
23. belyavsky 3 01.04.21 08:50 Сейчас в теме
в последнем обновлении опять все поломали :(
24. belov-k 02.04.21 10:17 Сейчас в теме
Что-то я немного не понимаю, надо отправлять и Реестр ЭЛН, и Реестр прямых выплат?
В версии 3.1.14.465 появилась какая-то ошибка "Перед отправкой реестра прямых выплат для ЭЛН требуется отправить реестр ЭЛН."
Вроде до этого всегда отправляли только Реестр прямых выплат.
25. user697419_firmamateko 05.04.21 10:12 Сейчас в теме
Здравствуйте.
Обновил сейчас ЗУП до версии 3.1.17.135 и расширение перестало работать. Скачал уже новую версию приложения для ЗУП 3.1.17.94, но и оно не работает, выдает ошибку (см. скриншот). Кстати, такая же ошибка выходит и когда я пытаюсь зайти в Администрирование - Пользователи.
Версия платформы 1С 8.3.18.1363 (это так, инфа на всякий случай, хотя на этой версии платформы с ЗУП 3.1.17.60 все работает отлично).

Стоит ждать обновления расширения или проще откатиться на версию 3.1.17.60?
Прикрепленные файлы:
26. as7bs 196 06.04.21 07:45 Сейчас в теме
(25) Постараюсь в ближайшее время обновить.
27. user697419_firmamateko 06.04.21 09:38 Сейчас в теме
28. as7bs 196 07.04.21 17:49 Сейчас в теме
(25)
(27)
Добавил расширение для релиза 3.1.17.135 (думаю должно работать и на 3.1.14.465)
29. user697419_firmamateko 09.04.21 11:03 Сейчас в теме
(28) Пока все работает без ошибок, спасибо. (версия 3.1.17.135)
30. mafey 1 13.04.21 20:23 Сейчас в теме
Можно как-то получить обновление?
31. user892471 9 15.04.21 08:40 Сейчас в теме
3.1.17.138 не работает

Ошибка инициализации модуля: ФайлРеестраФССвФормате1_7_6_АС Документ.РеестрСведенийНеобходимыхДляНазначенияИВыплатыПособий.МодульМенеджера
по причине:
{ФайлРеестраФССвФормате1_7_6_АС Документ.РеестрСведенийНеобходимыхДляНазначенияИВыплатыПособий.МодульМенеджера(89,22)}: Процедура или функция с указанным именем не определена (ПредставлениеСтатусаНалогоплательщикаДляРеестра)
ROW.RESIDENT_FLAG = <<?>>ПредставлениеСтатусаНалогоплательщикаДляРеестра(СтруктураДанных.СтатусНалогоплательщикаПолучателя);
{ФайлРеестраФССвФормате1_7_6_АС Документ.РеестрСведенийНеобходимыхДляНазначенияИВыплатыПособий.МодульМенеджера(174,23)}: Процедура или функция с указанным именем не определена (ОставитьТолькоЦифрыВСтроке)
ROW.ACCOUNT = <<?>>ОставитьТолькоЦифрыВСтроке(СтруктураДанных.НомерЛицевогоСчета);
32. as7bs 196 15.04.21 15:50 Сейчас в теме
(31) Какая версия скачана? Последняя? 1С случайно не под толстым клиентом запущена?
Оставьте свое сообщение

См. также

Трудовой договор, Дополнительное соглашение к трудовому договору, Лист ознакомления, Договор о материальной ответственности, Договор о коммерческой тайне, Согласие на обработку персональных данных для ЗУП 3.1 Промо

Печатные формы документов Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Комплект печатных форм для отдела кадров для документов Прием на работу и Кадровый перевод: Трудовой договор, Доп. соглашение к трудовому договору, Лист ознакомления с локальными нормативными актами, Договор о полной материальной ответственности, Договор о неразглашении коммерческой тайны, Согласие на обработку персональных данных.

2 стартмани

12.03.2019    37093    209    Asenka    64    

Справка 2-НДФЛ для ЗУП 2.5 / ЗУП 3.1 (Приложение № 5 к Приказу ФНС России от 02.10.2018 № ММВ-7-11/566@)

Зарплата Справки Зарплата v8 v8::СПР ЗУП2.5 ЗУП3.x БУ НДФЛ Абонемент ($m)

Печатная форма Справки 2-НДФЛ для ЗУП 2.5 / ЗУП 3.1 Форма с 2019 года Приложение № 5 к Приказу ФНС России от 02.10.2018 № ММВ-7-11/566@

1 стартмани

10.01.2019    27469    148    prime9    20    

Проверка действительности паспортов, проверка ФЛ на негатив в ЗУП 3.1

Бухгалтерские Управление персоналом (HRM) Управление персоналом (HRM) v8 v8::СПР ЗУП3.x Россия Абонемент ($m)

Обработка проверки действительности паспортов физических лиц в 1С ЗУП 3.x. Обработка обращается к API сервису проверки паспортов и открытых реестров. При работе в демо режиме обращение к сервису происходит с задержкой в 2 секунды. Проверка ФЛ на негатив осуществляется по следующим открытым реестрам: реестр дисквалифицированных лиц, реестр массовых руководителей, реестр массовых учредителей, реестр лиц причастных к террористической деятельности, открытый реестр недействительных паспортов. Не работает в демо режиме.

1 стартмани

04.11.2018    21450    19    user718500    4    

Проверка и корректировка данных по выплате зарплаты

Закрытие периода Бухгалтерские Анализ учета Зарплата Зарплата v8 v8::СПР ЗКГУ3.0 ЗУП3.x Россия БУ Госбюджет Абонемент ($m)

Обработка показывает остатки и движения взаиморасчетов с сотрудниками. Также обработка может откорректировать сумму остатков. Конфигурации: "Зарплата и управление персоналом" , релиз не ниже 3.1.2.105 и "Зарплата и кадры государственного учреждения" , релиз не ниже 3.1.2.105.

2 стартмани

08.06.2018    32303    205    APTEM_SLV    16    

Настройки отчета "Анализ начислений и удержаний" для ЗУП/ЗГУ 3.1 Промо

Бухгалтерские Зарплата Зарплата v8 v8::СПР ЗКГУ3.0 ЗУП3.x НДФЛ ФОМС, ПФ, ФСС Абонемент ($m)

Несколько полезных настроек отчета "Анализ начислений и удержаний" для зарплаты редакции 3.1. В состав входят настройки: Свод в разрезе налогообложения, Сводные данные для статистики, Реестр пособий, Расчетная ведомость по зарплате, Свод в разрезе финансирования, Отклонения от режима работы, Свод по зарплате в разрезе ИФНС, Начисления с детализацией отсутствий, Лицевые счета сотрудников, Распределение отпусков, Сводка затрат

2 стартмани

03.05.2018    46394    299    the1    45    

Трудовой договор, Дополнительное соглашение, Материальная ответственность, Коллективная материальная ответственность, Кадровый перевод, Индексация, Т-53 для ЗУП 3 внешние (7 печатных форм). Создание ведомостей по каждому сотруднику одной кнопкой

Печатные формы документов Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::СПР ЗУП3.x БУ Абонемент ($m)

1. Комплект из 6 печатных форм для документов: Прием на работу, Индексация, Кадровый перевод, Кадровый перевод списком для ЗУП 3.1.11 и более ранних Трудовой договор, дополнительное соглашение, договор личной материальной ответственности, договор коллективной материальной ответственности, индексация, Ведомость Т-53 без лишних строк. Не требуется изменения конфигурации. Подключается через стандартное подключение внешних обработок. 2. Обработка для создания ведемостей из начисления зарплаты. 3. Расширение конфигурации для ЗУП 3.1.11 и КА 2.4.6 для редактирования стажа как в ЗУП 2.5 (Из трудовой деятельности сотрудника. Если ввели строки трудовой деятельности, то стаж считается до даты приема сотрудника).

1 стартмани

26.01.2018    54411    508    p.ugrumov    98    

Проверка данных после неполного ("нового") переноса из ЗУП 2.5 в ЗУП 3.1

Зарплата Бухгалтерский учет Перенос данных из 1C8 в 1C8 Зарплата v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Описаны данные, которые необходимо проверить после неполного ("нового") переноса из ЗУП 2.5 в ЗУП 3.1. Описано, на что необходимо обратить внимание, где найти перенесенные данные, что НЕ переносится, где найти настройки.

1 стартмани

17.01.2018    33579    149    utrumar    3    

Себестоимость реализованной продукции по периодам выпуска в УПП (для РАУЗ, бухгалтерский учёт)

Производство готовой продукции (работ, услуг) Бухгалтерские Производство готовой продукции (работ, услуг) v8 УПП1 Россия БУ Абонемент ($m)

Отчёт показывает распределение себестоимости реализованной продукции по периодам. Продукция по периодам выпуска распределяется на полуфабрикаты по периодам выпуска полуфабрикатов. Затем выполняется разузлование полуфабрикатов до уровня материалов. Отчёт может быть полезен для предоставления результатов деятельности предприятия акционерам предприятия.

8 стартмани

29.12.2017    31319    60    Designer1C    15    

Анализ НДФЛ и сверка данных учета при подготовке 2-НДФЛ (ЗИК 1.0, ЗУП 2.5, ЗГУ 3.1, ЗУП 3.1) Промо

Анализ учета Налоговые Бухгалтерские Зарплата Зарплата v8 v8::СПР v8::СКД КА1 ЗУП2.5 ЗКБУ УПП1 БУ НДФЛ Абонемент ($m)

Два в одном. Наглядная информация об исчисленном налоге, и налоге, учтенном в справках, о суммах начислений по своду и о доходах, включенных в справки. Все это в разрезе физических лиц, так что станет очевидно, какой сотрудник не включен в справки, у кого недоучтен доход, кому неверно предоставлен вычет, а у кого неверно исчислен, удержан или перечислен налог.

1 стартмани

28.01.2016    38913    169    the1    11    

Справка о заработной плате и других доходах (измененная форма №46)

Справки Зарплата Зарплата v8 v8::СПР ЗКГУ3.0 Россия БУ Абонемент ($m)

Форма разработана для автоматизированного формирования справки по форме № 46. Внешний отчет с возможностью пользовательских настроек.

3 стартмани

24.11.2017    46805    55    agospodarin    15    

Налоги и взносы (кратко) по подразделениям и сотрудникам. ЗУП 3

Бухгалтерские Зарплата Зарплата v8 v8::СПР ЗУП3.x Россия БУ НДФЛ ФОМС, ПФ, ФСС Абонемент ($m)

Отчет "Налоги и взносы (кратко)" в разрезе подразделений и сотрудников.

3 стартмани

13.11.2017    40678    177    tritonof    11    

Контроль учёта спецодежды

Бухгалтерские Анализ учета Учет ТМЦ Учет ТМЦ v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Отчет предназначен для выявления ошибок возникших в бухгалтерском учёте специальной одежды в эксплуатации.

8 стартмани

08.09.2017    37031    44    sansys    15    

Универсальный реестр документов с возможностью вывода данных из табличных частей Промо

Бухгалтерские Управленческие v8 1cv8.cf Абонемент ($m)

-Возможность выводить числовые данные из табличных частей документов, такие как "Количество", "Сумма", "СуммаНДС" и др. При этом такие реквизиты, как "Цена", "Коэффициент", "ПроцентСкидок" не выводятся, так как это не имеет смысла. -Возможность выбирать выводимые документы. -Возможность выбирать выводимые реквизиты (при этом, если выбрано несколько документов, то можно выводить только реквизиты, общие для всех выбранных документов). -Возможность накладывать отборы на выводимые реквизиты. -Возможность выбора реквизитов, по которым проводить упорядочивание.

1 стартмани

31.10.2013    51042    678    Kubik1984    49    

Универсальная ведомость (отчет) по РАУЗ (управленческий и регламентированный учет)

Бухгалтерские Налоговые Управленческие v8 КА1 УПП1 БУ НУ УУ Абонемент ($m)

Универсальные отчеты, раскрывающие регистры РАУЗ (УчетЗатрат, УчетЗатратРегл) по всем доступным реквизитам, для конфигураций КА 1.1, УПП 1.3. По функциональности эквивалентны типовым отчетам "Ведомость по учету МПЗ", "Ведомость по учету затрат", но отличаются простыми и менее капризными настройками (по мнению автора), более удобной расшифровкой, решенной проблемой с расшифровкой по периодам.

2 стартмани

05.06.2017    37635    85    stvorl    0    

Отчет-календарь СКД

Практика программирования Управленческие Бухгалтерские Банковские операции Банковские операции v8 v8::БУ 1cv8.cf БУ Абонемент ($m)

Хотите повысить наглядность отчетов и выходных форм? Достаточно совместить их с календарем ) Это довольно легко реализовать при помощи СКД.

1 стартмани

01.06.2017    29451    59    kiberiq    13    

Отчет ОСВ++ для 1С:Бухгалтерии 3.0 - расшифровка оборотов, добавление любого количества субконто без изменения конфигурации и не только

Бухгалтерские Оборотно-сальдовая ведомость, Анализ счета Оборотно-сальдовая ведомость, Анализ счета v8 v8::БУ БП3.0 БУ Абонемент ($m)

Отчет ОСВ++, наряду с возможностями типовых отчетов ОСВ, ОСВ по счету, Карточка счета, Анализ субконто и Карточка субконто, позволяет: Консолидировать данные ОСВ нескольких организаций; Добавлять произвольное количество субконто - наряду со стандартными, в качестве субконто могут быть задействованы любые реквизиты и дополнительные сведения документов движения; Получать расшифровки оборотов по корреспондирующим счетам и субконто; Получать данные оборотов с расшифровкой по документам движения; Формировать сальдо по оборотным субконто; Выводить данные по счетам и аналитикам, обороты по которым в выбранном периоде равны нулю (типовой отчет "ОСВ по счету" в подобной ситуации данных не выводит). Внесение изменений в конфигурацию не требуется.

3 стартмани

22.03.2017    45782    333    TSSV    9    

П-4 и П-4 (НЗ) за 1 квартал 2021г. (январь-март) для ЗУП 2.5 с ОКВЭД 2 (в новой ред. № 412 от 24.07.2020) (ОКУД 0606010)

Статистические Статистики Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8::СПР ЗУП2.5 Россия БУ Абонемент ($m)

1) П-4 в новой редакции за 1 квартал 2021 г. для ЗУП 2.5 и УПП с отбором по подразделению и КПП, ред. №412 от 24.07.2020 с указанием новых кодов статистики ОКВЭД2 реализована выгрузка в электронном виде в соответствии с XML-шаблоном от 21.01.2021г. 2) П-4 (НЗ) в новой редакции за 1 квартал 2021 г. для ЗУП 2.5 и УПП - с отбором по подразделениям и КПП, в ред. №412 от 24.07.2020.выгрузка в электронном виде в соответствии с XML-шаблоном от 20.02.2021,

1 стартмани

13.02.2017    63503    1142    ilnet    91    

T-11а. Премии работников организации (отображение в %) для ЗУП 3.1

Печатные формы документов Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Внешняя печатная форма приказа о поощрении сотрудников (Т-11а отображение в %) для ЗУП 3.1 подключаемая к документу "Премия". Добавляется через Сервис - Дополнительные отчеты и обработки.

1 стартмани

06.02.2017    20865    45    chervic    0    

Универсальный бухгалтерский отчет Промо

Оборотно-сальдовая ведомость, Анализ счета Бухгалтерские Оборотно-сальдовая ведомость, Анализ счета v8 v8::БУ КА1 БП2.0 УПП1 БУ Абонемент ($m)

Стандартные отчеты на СКД из 1С:Бухгалтерия предприятия 8 КОРП, адаптированные для: 1С:Бухгалтерия предприятия 8, 1С:Бухгалтерия предприятия 8 для Украины, 1С:Бухгалтерия для Беларуси, 1С:Управление производственным предприятием, 1С:Управление производственным предприятием для Украины, 1С:Управление торговым предприятием для Украины.

1 стартмани

24.08.2009    21181    2449    bonv    173    

Книга покупок по разным ставкам НДС для Бухгалтерии 3.0

Бухгалтерские Закрытие периода Закрытие периода v8 v8::БУ БП3.0 Россия БУ НДС Абонемент ($m)

Отчет по НДС. КНИГА ПОКУПОК по разным ставкам НДС ДЛЯ БУХГАЛТЕРИИ 3.0. Типовая книга покупок не показывает все сведения по суммам по разным ставкам НДС. Отчет создан для самопроверки перед формированием отчетности.

1 стартмани

21.09.2016    20808    30    overloader    2    

6-НДФЛ - Формирование, проверка, корректировка, перенос в типовой отчет. ЗУП 2.5 / УПП 1.3 / ЗиКБУ

Налоговые Бухгалтерские Зарплата Зарплата v8 v8::СПР ЗУП2.5 ЗКБУ УПП1 Россия БУ НДФЛ Абонемент ($m)

Формирование 6-НДФЛ по первичным документам (НЕ ПО РЕГИСТРАМ) для ЗУП 2.5 / УПП 1.3 / ЗиКБУ. Всё что требуется - это правильно заполнить даты выплаты дохода в документах начисления!

1 стартмани

27.07.2016    52628    587    madonov    190    

Краткий регистр налогового учета НДФЛ 2016

Бухгалтерские Налоговые Зарплата Зарплата v8 v8::БУ v8::СПР БП3.0 ЗУП3.x Россия БУ НДФЛ Абонемент ($m)

C 2016 года у ИФНС повысились требования к учету НДФЛ. Предлагаю вам отчет "Краткий регистр налогового учета НДФЛ", компактный, простой и информативный. Самое главное - от обычного "Регистр налогового учета НДФЛ" отличается размерами.

2 стартмани

18.04.2016    35368    26    Craig    6    

Простой отчет по фактическим отпускам

Бухгалтерские Управленческие Управление персоналом (HRM) Учет рабочего времени Управление персоналом (HRM) Учет рабочего времени v8 ЗУП2.5 УПП1 БУ УУ Абонемент ($m)

Отчет позволяет быстро сформировать как сводную таблицу, сгруппированную по видам отпусков, так и с легкостью получить детальный список по всем отпускам за указанный период.

2 стартмани

18.08.2015    37976    88    VBod    5    

Формирование 6-НДФЛ в ЗУП 2.5

Регламентированная отчетность Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 1cv8.cf Россия БУ НДФЛ Абонемент ($m)

Формирование отчетности 6-НДФЛ на практическом примере.

1 стартмани

04.04.2016    79407    833    nsr17    41    

Откуда берутся данные 6-НДФЛ в ЗУП 2.5

Бухгалтерский учет Зарплата Зарплата v8 ЗУП2.5 Россия БУ НДФЛ Абонемент ($m)

Как заполняются данные 6-НДФЛ? Файл с картинками и описанием дополнений учета НДФЛ в ЗУП 2_5_99 по сравнению с прежними версиями.

1 стартмани

03.02.2016    181032    156    milov.aleksey    126    

1С:Предприятие 8. Нужные отчеты. В копилку бухгалтера и специалиста 1С. Обновлено 07.03.2016 г.

Бухгалтерские Оборотно-сальдовая ведомость, Анализ счета Учет доходов и расходов Оборотно-сальдовая ведомость, Анализ счета Учет доходов и расходов v8 БП2.0 Украина БУ Абонемент ($m)

Пакет нужных отчетов - "Остатки и движение запасов" , "Остатки и движение денег", "Сравнительный анализ себестоимости и цен реализации". СКД и Построитель отчетов не использованы. НЕ управляемые формы. Запросы строились только по данным Хозрасчетного плана счетов. Сравнительный анализ - очень нужный отчет для предприятий, реализующих продукцию собственного производства. На сумму продаж ниже себестоимости нужно доначислить доход со всеми вытекающими. Отчет позволит своевременно выявить и откорректировать плановую стоимость продукции.

1 стартмани

13.01.2016    32178    39    kompas-dm    8    

Расшифровка по Основным средствам для расчета налога на имущество по 2-му и 3-му разделам декларации "Авансы по налогу на имущество".

Бухгалтерские Налоговые Учет ОС и НМА Учет ОС и НМА v8 v8::БУ v8::УФ КА1 БП2.0 УПП1 БУ НУ Налог на имущество Абонемент ($m)

Отчет "Расшифровка отчета 'Авансы по налогу на имущество' по 2-3 разделам" предназначен для проверки и контроля правильности расчета регламентированного отчета "Авансы по налогу на имущество" в разрезе Основных средств. Предоставляет ряд дополнительных данных по состоянию ОС организации на текущий момент согласно данным хозрасчетного регистра. Написан на основании стандартных процедур заполнения регламентированных отчетов, но дополнительно показывает данные в разрезе групп ОС и каждого ОС, согласно данным 2-го и 3-го разделов стандартного отчета. Версия для обычного приложения тестировалась на УПП 1.3, но должно работать в БУ, БУ КОРП 2.0, КА, БАУ и БАУ КОРП (по крайней мере для обычных /неуправляемых/ приложений). Версия для управляемого приложения тестировалась на БП 3.0. В отчете учтены ОС, введенные в эксплуатацию после 2013 и учтены изменения, введенные в 2017 г. Предусмотрено три варианта отчета: 1. Для обычного приложения 8.1-8.3 платформ; 2. Для управляемого приложения 8.2 - 8.3 платформ; 3. Универсальный вариант, который подходит для обоих типов конфигураций: для обычного и управляемого приложений (удобно, если на предприятии используются оба типа - и обычные, и управляемые приложения).

2 стартмани

04.09.2015    44652    310    vik2006    70    

Интерактивная оборотно-сальдовая ведомость 3.0 для управляемых форм

Бухгалтерские Анализ учета Налоговые Оборотно-сальдовая ведомость, Анализ счета Оборотно-сальдовая ведомость, Анализ счета v8 v8::БУ v8::УФ КА1 УНФ БГУ ERP2 БП3.0 БУ НУ Абонемент ($m)

Полностью универсальная Оборотно-сальдовая ведомость, также включающая возможности ОСВ по счету, Анализа счета и другие. С возможностью интерактивных разворотов в пару кликов по любым разрезам регистра бухгалтерии с подключением к типовым механизмам конфигураций расшифровки.

2 стартмани

19.07.2015    95598    3575    Леонов Александр    120    

Конструктор трудовых договоров WORD для типовой конфигурации 1C: Зарплата и управление персоналом 3.1

Универсальные печатные формы Пакетная печать Печатные формы документов Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Внешняя печатная форма или обработка "Конструктор трудовых договоров на основе документов формата Word". Конструктор автоматически подставляет реквизиты в документ формата Word. Подходит для типовой конфигурации 1С: ЗУП 3.1.

1 стартмани

14.07.2015    68872    640    ni032mas    110    

Сверка счетов 62.02 и 76.АВ в разрезе договоров и документов расчета. Поиск расхождений. СКД. Обычное и управляемое приложение. 8.х

Бухгалтерские Налоговые Анализ учета Дебиторская и кредиторская задолженность Дебиторская и кредиторская задолженность v8 БП2.0 Россия БУ НУ Абонемент ($m)

Отчёт показывает разницу между 76.АВ и 62.02 (*18/118) по контрагентам в разрезе договоров и документам расчета. Разница рассчитывается как по остаткам, так и по оборотам. Если разница не равна 0, то проблемная позиция выводится в отчёт. Написано на СКД, работает в управляемом и обычном приложениях 8.х Есть настройка, позволяющая отфильтровать договора по виду расчётов. Можно убрать строки, в которых разница между 76 и 62 несколько рублей или копеек, со знаком + или -

1 стартмани

08.07.2015    42552    125    UPSoft    20    

Отчет по взаиморасчетам по всем счетам бух.учета для УПП-1.3, КА-1.1 и БП-2.0

Бухгалтерские Анализ учета Управленческие Дебиторская и кредиторская задолженность Займы, кредит, лизинг Дебиторская и кредиторская задолженность Займы, кредит, лизинг v8 Платформа 1C v8.2 КА1 БП2.0 УПП1 Россия БУ УУ Абонемент ($m)

Оборотно-сальдовая ведомость по всем счетам бухгалтерского учета по взаиморасчетам для контрагентов В отчете можно одновременно получить ОСВ (оборотно-сальдовую ведомость) сразу по всем счетам БУ, которые используются для взаиморасчетов В отчете можно отобрать произвольный перечень субсчетов с разных счетов : 60, 62, 66, 67, 76, 58 и т.д. А еще отчет позволяет проконтролировать закрытие авансов на 60 и 62 счетах в разрезе контрагентов и договоров

1 стартмани

22.06.2015    42211    152    Designer1C    13    

Справка о начисленной зарплате

Справки Зарплата Зарплата v8 ЗУП2.5 ЗКБУ Россия БУ Абонемент ($m)

Справка о начисленной зарплате за выбранный период по месяцам

1 стартмани

26.05.2015    31285    56    ia57    4