Доработки обмена "УТ 10.3 - интернет-магазина Shop-Script"

Публикация № 899718

Учет и отчетность - Оптовая торговля

Webasyst Shop-Script обмен с сайтом интернет-магазин

Доработки типового обмена между УТ 10.3 и интернет-магазином Shop-Script на движке Webasyst: выгрузка нулевого количества товара, номенклатурных групп вместо групп номенклатуры и дополнительного описания номенклатуры.

Интернет-магазин Shop-Script на движке Webasyst  проявил себя достаточно гибко в плане интеграции с 1С. Выбирать движок не пришлось - этот выбор сделали за меня клиенты. Зато потребовалось доработать выгрузку товаров.

Входная информация.

Типовой обмен происходит по формату 1С (CommerceML) из1С через меню "Сервис - Обмен данными с Web-сайтом".

По умолчанию,

1) по товарам выгружаются все группы по иерархии номенклатуры;

2) нулевые или минусовые остатки не выгружаются;

3) дополнительное описание номенклатуры выгружается в поле "краткое описание".

Из-за чего сыр-бор.

1) Справочник Номенклатура за годы накопил структуру групп по брендам "Х-фактори", "Олерон", а не по функциональной общности "Маникюрный набор", "Краска", "Оборудование"  и т.д. - что для интернет-магазина заказчика не удобно.

2) Отсутствующие товары отображаются на сайте со знаком бесконечность (см. рис.)

3) На сайте не видно подробное описание товара.

Что было сделано в 1С.

1) группы товаров при анализе xml-файла import.xml имеют следующую структуру - см. рис. (на рисунке представлен уже результат доработок 1с)

Как видно из рисунка, достаточно сделать подмену групп номенклатуры - на номенклатурные группы. Что и было сделано - в представленной внешней обработке имеются места доработок кода с комментарием "доработка+". Внешняя обработка является независимой работоспособной "капсулой".

Как мы видим из кода, при обмене происходит вызов обработки "Обмен с сайтом".

 

Процедура ВыполнитьАвтообмен(Настройка, ФлагАвтообмена = Истина) Экспорт

    Если НЕ
ЗначениеЗаполнено(Настройка) Тогда

        Возврат;

    КонецЕсли;

   
ОбработкаОбмена = Обработки.ОбменССайтом.Создать();
   
ОбработкаОбмена.НастройкаСсылка = Настройка;
   
ОбработкаОбмена.ВыгрузитьДанные
();

КонецПроцедуры

Достаточно эту обработку заменить на представленную в публикации, а в настройках обмена надо удалить строку в таблице соответствия классификаторов - см. рис.

 

2) Доработка количества также представлена в обработке - см. листинг.

  

 //типовой код
Если Остаток > 0 Тогда
   
ДобавитьУзелCML(СписокЗначенийCML, "Количество", ФорматЗначенияДляCML(Остаток, мФорматСумм));
КонецЕсли;


//доработка+
Если Остаток <= 0 Тогда
   
ДобавитьУзелCML(СписокЗначенийCML, "Количество", "0");
КонецЕсли;

3) Для того чтобы описание номенклатуры попало в поле "Описание" интернет-магазина, надо поставить галочку "Дополнительное описание номенклатуры в формате HTML"  - в карточке Номенклатуры - см.рис.

Вроде очевидно, но без документации пришлось проводить эксперименты по выгрузке товаров.

Обработка создана и протестирована на платформе 1С:Предприятие 8.2 (8.2.19.130), конфигурации "Управление торговлей", редакция 10.3 (10.3.47.3).

На этом все.


См. также:

Как эффективно использовать Инфостарт

Список реализаций + структура подчиненности + реестр документов SALE

Список заказов поставщикам + структура подчиненности SALE

Список заказов покупателей + структура подчиненности SALE

Договоры для 1с-ника ТОП-скачиваний

Адаптивная сетка расписания (Свой адаптивный планировщик) нестанДАрт

Два механизма, которые ускорили работу бухгалтеров в 1С нестанДАрт

Мини-CRM для УТ 10.3

Расчет банковских (рабочих) дней нестанДАрт

Шаблоны кода в режиме 1С:Предприятие SALE

Доработка конфигурации Конвертация Данных

Планирование платежей. Прогнозирование прибылей и убытков

Ввод показателей план-факта БП 3.0 Know-how

Инвентаризация личного опыта Для новичков 1С

Большие запросы: взгляд на проблему нестанДАрт

Технология создания коммерческих разработок Know-how

Андроид-решение для создания заказов в 1С Know-how + нестанДАрт

Отчет Остатки и цены

Печать ценников с одной и двумя ценами 55х40, 100х60, 140х200

Загрузка данных о розничных продажах из магазинов Intimissimi (Интимиссими) и Calzedonia (Кальцедония) в УТ

Скачать файлы

Наименование Файл Версия Размер
Доработки обмена "УТ 10.3 - интернет-магазина Shop-Script"

.epf 48,89Kb
02.06.20
2
.epf 48,89Kb 2 Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Счет на оплату с НДС 20%

Печатные формы документов Оптовая торговля Оптовая торговля v8 v8::ОУ БП2.0 УТ10 Абонемент ($m)

Счет на оплату с НДС 20% и уведомлением, что НДС изменится с 01.01.2019г.

1 стартмани

12.11.2018    11194    27    Rustig    13    

Группировка товаров при печати чеков ККМ

Печатные формы документов ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 КА1 УТ10 БУ Абонемент ($m)

Товары группируются по своей иерархии товаров. Длина чека ККМ сокращается в разы. Общая сумма чека ККМ и общее количество товаров не изменяется.

2 стартмани

07.09.2018    8167    0    Rustig    13    

Внешняя Торг-12 со штрихкодом для БП 2.0

Печатные формы документов Оптовая торговля Оптовая торговля v8 v8::БУ БП2.0 Россия БУ Абонемент ($m)

Представлена внешняя печатная форма Торг-12 для БП 2.0 с выводом штрихкода. В качестве штрихкода задается номер заказа. В базе штрихкоды хранятся как дополнительные реквизиты. Предложенный способ (идея) использования штрихкодов распространяется на любую конфигурацию.

1 стартмани

05.11.2016    13455    6    Rustig    0    

Отправка пакета документов по электронной почте (в формате PDF/XLS/HTML/MXL/ODS) Промо

Печатные формы документов Пакетная печать Email Оптовая торговля Оптовая торговля v8 БП2.0 КА1 УПП1 УТ10 Россия БУ Абонемент ($m)

С помощью обработки можно нажатием одной кнопки отправить пакет документов контрагенту по электронной почте. Теперь не надо заходить в каждый документ, формировать нужную печатную форму, сохранять на диск, а потом собирать в одном письме. Все это за вас сделает программа самостоятельно. Все, что требуется от пользователя - просто выбрать документ в программе! Доступны варианты обработки для обычного и управляемого приложения!

2 стартмани

22.04.2015    52334    33    trendy    20    

Внешняя УПД для реализации (УТ 10.3.32 и 10.3.43.1) - две доработанные обработки: до и после 1 июля 2017 г + типовая внешняя УПД

Печатные формы документов Оптовая торговля Оптовая торговля v8 v8::ОУ УТ10 Россия БУ Абонемент ($m)

В печатной форме УПД вместо "Договора" (поле Основание) теперь подставляется "Заказ покупателя", даже если взаиморасчеты ведутся "по договору в целом". Представлены две внешние обработки УПД - разработанные соответственно до и после 1 июля 2017 г. Также представлена третья обработка - полностью типовая внешняя УПД, которая подходит как для УПД до 1 июля, так и после 1 июля 2017г. Внимание! Не подходит под изменения от 1 октября 2017г.

1 стартмани

15.12.2015    18844    117    Rustig    8    

Счет на оплату покупателю + отправка по электронной почте Промо

Печатные формы документов Email Оптовая торговля Производство готовой продукции (работ, услуг) Оптовая торговля Производство готовой продукции (работ, услуг) v8 v8::БУ БП2.0 Россия БУ Абонемент ($m)

Внешняя печатная форма для документа "Счет на оплату покупателю". Отправляет по электронной почте сформированный файл печатной формы в формате *.xls.

1 стартмани

13.11.2012    26960    15    siranush    9    

Печать и подпись на счете. Авто отправка по электронной почте для Бухгалтерии и УТ Промо

Печатные формы документов Оптовая торговля Email Оптовая торговля v8 БП2.0 УТ10 Россия Абонемент ($m)

Подключаемая внешняя обработка позволяет формировать и отправлять счет с цветными печатью и подписями на электронную почту клиента

1 стартмани

10.04.2012    49380    100    PiterPen    92