Автоматическая загрузка выписок Сбербанк-бизнес онлайн с помощью 1С:ДиректБанк для УТ 11

Публикация № 1148667 01.11.19

Бухгалтерский учет - Банковские операции

ДиректБанк автоматическая загрузка выписок УТ 11

Позволяет грузить выписки из Сбербанка онлайн в автоматическом режиме. Требуется один раз авторизация по СМС при начале работы системы.

Идея взята из этой публикации Загрузка выписок в УНФ  и адаптирована под УТ 11 

Принцип работы 1С:ДиректБанк: 
Запрашиваем выписку, авторизовываемся, подтверждаем авторизацию СМС паролем и получаем выписку. Все хорошо работает, но для того что бы спустя время повторно получить выписку, приходится опять проходить авторизацию.
Само подключение подключение к 1С:ДиректБанк - не рассматриваем, так как в интернете полно инструкций, да и встроенная обработка по подключению полностью автоматизирована.

О способе: 
Эмпирически было замечено, что сбербанк после авторизации для получения выписки инициирует vpn соединение и завершает сессию при отсутствии активности спустя некоторого времени. Так что мы будем использовать эту особенность для многократного получения выписок, по сути постоянно генерируем активность в сессии не давай ей закрыться.
В общем этот способ хоть и костыль, но позволяет нам оперативно видеть движения по расчетному счету и минимизировать человеческий фактор.

Способ безопасен, ибо дает возможность только получения выписок, для отправки платежей все равно потребуется подписывание с помощью СМС.

Из минусов, придется держать открытым 1С с запущенной формой загрузки выписок

 

1. Добавляем новое расширение, называем как хотим и снимаем оба флажка в списке расширений.

2. Добавляем в расширение форму "Обработка.КлиентБанк.ФормаЗагрузка"

3. В расширяемой форме, добавляем новый реквизит "Таймер", тип Число. Установка Таймера - будет отключать все. Для удобства включаем у реквизита "Таймер" флаг "Сохранения", что бы значение таймера сохранялось.

4. Добавляем в удобное для вас место на форме. (смотри скриншот )

5. Вставляем код в модуль расширяемой формы  "Обработка.КлиентБанк.ФормаЗагрузка"


// "нажимаем" кнопку "Запросить выписку" 
&НаКлиенте
Процедура РоботСбербанк_ЗапроситьЭлектроннуюВыпискуБанка() экспорт
	
//	Делаем отметку счетов для загрузки
	Для каждого Счет Из Объект.БанковскиеСчета Цикл
		Если Счет.Загружается Тогда
			Продолжить;
		КонецЕсли;
		Если Счет.ПрямойОбмен Тогда
			Счет.Пометка = Истина;
		КонецЕсли;
	КонецЦикла;
//Программно нажимаем кнопку запросить выписку	
	ИмяНужнойКоманды = "ЗагрузитьДокументы"; 
	// Тут просто имя команды как в конфигураторе. 
	НужнаяКоманда = ЭтаФорма.Команды.Найти(ИмяНужнойКоманды); // Находим команду на форме 
	ЗагрузитьДокументы(НужнаяКоманда);  
КонецПроцедуры


&НаКлиенте
&После ("ЗавершитьЗагрузку") 
Процедура РоботСбербанк_После_ЗавершитьЗагрузку()
	
    // Если у нас установлен Таймер повторного запроса выписки
    Если Таймер > 0  тогда
        ПодключитьОбработчикОжидания("РоботСбербанк_ЗапроситьЭлектроннуюВыпискуБанка", Таймер, Истина); // Устанавливаем Таймер на повторную загрузку выписки.
        возврат;
    КонецЕсли;
  
КонецПроцедуры

6. Добавляем в расширение "ОбщийМодуль.ОбменСБанкамиСлужебныйКлиент"

7. Вставляем в модуль код, чтобы убрать не нужный интерактивный вопрос.

&Вместо ("ПослеФормированияИОтправкиЗапросовВыпискиСбербанк")

// Асинхронный обработчик, вызываемый из ОбменСБанкамиКлиент.ПолучитьВыпискуБанка
//
// Параметры:
//  Результат - Структура - см. описание в ДлительныеОперацииКлиент.ОжидатьЗавершение
//  ДополнительныеПараметры - Произвольный - значение, которое было указано при создании объекта ОписаниеОповещения.
//
Процедура РоботСбербанк_ПослеФормированияИОтправкиЗапросовВыпискиСбербанк(Результат, ДополнительныеПараметры) Экспорт
	
	ПараметрыЖурналирования = ОбменСБанкамиСлужебныйВызовСервера.ПараметрыЖурналирования(
		ДополнительныеПараметры.НастройкаОбмена);
		
	Если ПараметрыЖурналирования.ИспользоватьЖурналирование Тогда
		СохранитьЖурналВФайл(ДополнительныеПараметры.НастройкаОбмена, ПараметрыЖурналирования.КаталогДляЖурналирования);
	КонецЕсли;
	
	Если Результат = Неопределено Тогда // задание было отменено пользователем
		Возврат;
	КонецЕсли;
	
	Если Результат.Статус = "Ошибка" Тогда
		ВидОперации = НСтр("ru = 'Отправка запросов выписок в Сбербанк'");
		ОбработатьОшибку(ВидОперации, Результат.ПодробноеПредставлениеОшибки, Результат.КраткоеПредставлениеОшибки,
			ДополнительныеПараметры.НастройкаОбмена);
	Иначе // выполнено
		РезультатОперации = ПолучитьИзВременногоХранилища(Результат.АдресРезультата);
		Если РезультатОперации.ГотовыеВыписки.Количество() Тогда
			ДополнительныеПараметры.Вставить("ГотовыеВыписки", РезультатОперации.ГотовыеВыписки);
			ОписаниеОповещенияОЗавершении = Новый ОписаниеОповещения(
				"ПолучитьВыпискуСбербанкаПослеВопросаОбИхНаличии", ЭтотОбъект, ДополнительныеПараметры);
			ТекстВопроса = НСтр("ru = 'В базе уже есть выписки банка за указанный период.
									|Загрузить выписки из базы или получить новые из банка?'");
			Кнопки = Новый СписокЗначений;
			Кнопки.Добавить(Истина, НСтр("ru = 'Загрузить из базы'"));
			Кнопки.Добавить(Ложь, НСтр("ru = 'Получить из банка'"));
			Кнопки.Добавить(КодВозвратаДиалога.Отмена);
			Заголовок = НСтр("ru = 'Выбор способа получения выписки'");
//			ПоказатьВопрос(ОписаниеОповещенияОЗавершении, ТекстВопроса, Кнопки, , Истина, Заголовок);
//Сразу грузим выписки без вопроса
	        ПолучитьВыпискуСбербанкаПослеВопросаОбИхНаличии(Ложь, ДополнительныеПараметры)
		ИначеЕсли РезультатОперации.МассивТикетов.Количество() Тогда // запросы были отправлены в банк и получены тикеты
			ВладелецФормы = ДополнительныеПараметры.Владелец;
			ПараметрыФормы = Новый Структура("МассивСообщенийОбмена, НастройкаОбмена, ГотовыеВыписки, ДатаНачала, ДатаОкончания,
											|ПринудительноеПолучениеВыписки, НомерСчета");
			ЗаполнитьЗначенияСвойств(ПараметрыФормы, ДополнительныеПараметры);
			ПараметрыФормы.Вставить("ВидОперации", "ПолучениеВыписки");
			ПараметрыФормы.Вставить("МассивТикетов", РезультатОперации.МассивТикетов);
			ПараметрыФормы.Вставить("МассивСообщенийОбмена", РезультатОперации.МассивСообщенийОбмена);
			ПараметрыФормы.Вставить("ГотовыеВыписки", Новый Массив);
			ОткрытьФорму("Обработка.ОбменСБанками.Форма.ЗапросВБанк", ПараметрыФормы, ВладелецФормы);
		ИначеЕсли РезультатОперации.ИспользуетсяТокен Тогда
			ДополнительныеПараметры.Вставить("ГотовыеВыписки", Новый Массив);
			ДополнительныеПараметры.Вставить("МассивСообщенийОбмена", РезультатОперации.МассивСообщенийОбмена);
			ОбработчикПослеПодписания = Новый ОписаниеОповещения(
				"ОтправитьЗапросВыпискиПослеПодписанияСбербанк", ЭтотОбъект, ДополнительныеПараметры);
			ПодписатьЭДСбербанк(
				ОбработчикПослеПодписания, ДополнительныеПараметры.НастройкаОбмена, РезультатОперации.МассивСообщенийОбмена);
		Иначе //отправка по логину, требуется установка сессии.
			ДополнительныеПараметры.Вставить("МассивСообщенийОбмена", РезультатОперации.МассивСообщенийОбмена);
			Обработчик = Новый ОписаниеОповещения(
				"ПолучитьВыпискиПослеБазовойАутентификацииСбербанк", ЭтотОбъект, ДополнительныеПараметры);
			ВыполнитьБазовуюАутентификациюСбербанк(Обработчик, ДополнительныеПараметры.РеквизитыНастройкиОбмена.ИмяВнешнегоМодуля,
				ДополнительныеПараметры.НастройкаОбмена, ДополнительныеПараметры.НастройкаОбмена);
		КонецЕсли;
		
	КонецЕсли;
	
КонецПроцедуры

Тестировалось на версии УТ 11.4.8.92

Скачать файлы

Наименование Файл Версия Размер
Автоматическая загрузка выписок Сбербанк-бизнес онлайн с помощью 1С:ДиректБанк для УТ 11:

.cfe 24,38Kb
2
.cfe 11.4.8.92 24,38Kb 2 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. star1k 20.01.20 14:26 Сейчас в теме
Добрый день! Подскажите пожалуйста, будет ли работать это расширение в ERP 2.4?
2. average 24 20.01.20 21:45 Сейчас в теме
Нужно проверять.
Есть нюанс
Сбербанк теперь хочет СМС раз в сутки.
Мы обошли эту проблему по другому.
Пришлось организовать передачу СМС с симкарты в 1С.
По факту оказалось, что технически загружать выписку не сложно.
3. AntoShiK86 20 19.03.21 13:37 Сейчас в теме
Здравствуйте будет ли работать в УТ11.4.12?
Оставьте свое сообщение

См. также

Управление деньгами - расширение для 1С:Бухгалтерии. Позволяет формировать платежный календарь на основании заявок на оплату и выставленных счетов

Банковские операции Бюджетирование и планирование Кассовые операции Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Бюджетный учет Управленческий учет Абонемент ($m)

Управление деньгами - расширение для 1С: Бухгалтерии, которое позволяет управлять денежными средствами организации. Формировать платежный календарь на основании заявок на оплату и выставленных счетов.

1 стартмани

20.05.2022    3097    15    chernodarov    6    

Оплата по QR СБП. Управление торговлей 11

Банковские операции Розничная торговля Эквайринг Платформа 1С v8.3 1С:Управление торговлей 11 Абонемент ($m)

Обработка позволяет обрабатывать платежи от клиентов в форме РМК. Оплата проводится как оплата картой на указанный в настройках эквайринговый терминал. Реализована возможность оформления возврата по ранее проведенной оплате. QR формируется непосредственно для оплаты, без промежуточных переходов и выхода из банковского приложения.

1 стартмани

28.06.2022    2416    37    Leo_A    34    

Модуль обмена с QIWI

Банковские операции WEB-интеграция Платформа 1С v8.3 Конфигурации 1cv8 Управленческий учет Абонемент ($m)

Компании, которые используют систему моментальных платежей QIWI, ценят ее за удобство по скорости выплат и для платежей по запросу. Но такие переводы сложны для учета, а при большом объеме проводимых операций отнимают много времени и превращаются в дополнительную головную боль. Мы сотрудничали с компаниями, которые отправляют большое количество платеже на QIWI, и часто слышали боль бухгалтеров о том, как им сложно работать с такими переводами. Поэтому мы автоматизировали выплаты через QIWI в 1С и создали модуль интеграции 1С c API QIWI Wallet и QIWI TopUp.

5 стартмани

25.05.2020    13549    2    Neti    10    

Загрузка выписок из АЦК в формате XLT файлов для БГУ 2.0

Обработка документов Банковские операции Кассовые операции Бюджетный учет Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия государственного учреждения Государственные, бюджетные структуры Россия Бухгалтерский учет Бюджетный учет Абонемент ($m)

Обработка позволяет загружать из выписки лицевого счета в формате XLT (АЦК) в 1С: Бухгалтерию государственного учреждения 2.0 документы Кассовое поступление/выбытие.

1 стартмани

11.02.2022    6442    12    kirill1c    0    

[Расширение] Автозаполнение суммы комиссии из Назначения платежа для БП 3

Банковские операции Эквайринг Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Абонемент ($m)

Расширение: выделение (автозаполнение, установка, заполнение) суммы комиссии банка для операций эквайринга по данным "Назначения платежа" для документа "Поступление на расчетный счет" для конфигурации 1С:Бухгалтерия предприятия, ред. 3.0 (базовая/проф/КОРП).

1 стартмани

15.06.2021    8025    48    zhuravlev_as    95    

Пакетное пробитие чеков на Онлайн-кассе при оплатах от физических лиц на расчетный счет

Банковские операции Кассовые операции Обработка документов Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Абонемент ($m)

Автоматизация процесса пробития чеков онлайн при поступлениях на расчетный счет от физических лиц. Помогает сократить трудозатраты таким организациям, как МФЦ, Управляющие компании и т.д. Подходит для 1С:Бухгалтерия 3.0 любой версии (базовая, ПРОФ, КОРП). Не изменяет конфигурацию. Конфигурация остается на поддержке (типовая).

2 стартмани

24.09.2019    30764    18    r.resh39    16    

Настройка оплаты по Системе Быстрых Платежей (СБП) через QR-код (на примере Газпромбанка)

Банковские операции Оптовая торговля СБП. Оплата по QR-коду Платформа 1С v8.3 Конфигурации 1cv8 Бухгалтерский учет Управленческий учет Абонемент ($m)

Обработка включает в себя механизм регистрации организации в СБП (Юр. лицо, счет, ТСП), запрос ссылки на оплату по выбранному нами договору и преобразование ее в QR-код. Клиенту остается только считать его и оплатить. После чего банк присылает нам платежки, где в назначении платежа указан договор, по которому была оплата, дата, плательщик. Предварительно нужно заключить договор с банком.

2 стартмани

30.03.2021    16983    105    pv94384    24    

Загрузка классификатора банков РФ 2021 г. в УТ 10.3, БП 2.0

Банковские операции Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Управление производственным предприятием Россия Абонемент ($m)

Внешняя обработка "Загрузка классификатора банков РФ" для БП 2.х , УТ 10.х, КА 1.х , УПП 1.3.х из нового формата классификатора БИК".

1 стартмани

21.01.2021    14520    234    darminov    11    

Загрузка выписки из клиент-банка в 1С:Предприятие 8.2 / 8.3 для 1С: Бухгалтерии Предприятия ред.2.0 Промо

Обмен с интернет-банком Банковские операции Зарплата Платформа 1С v8.3 1С:Бухгалтерия 2.0 Россия Бухгалтерский учет Абонемент ($m)

Эффективное решение для загрузки банковской выписки из Клиент-Банка в бухгалтерскую программу 1С:Бухгалтерия 2.0 (ПРОФ/КОРП) Требования к файлу экспорта выписки: поддержка формата 1С:Предприятие обмена с клиент-банками Автоматическая установка ключевых реквизитов документов: вид операции, корр.счет, субконто (Контрагенты, сотрудники, прочие доходы и расходы), контрагент Подстройка к любым особенностям учета движения денежных средств

10 стартмани

25.02.2013    119813    298    Designer1C    48    

Загрузка выписки из клиент-банка в 1С: Бухгалтерию ред.3.0 Промо

Обмен с интернет-банком Банковские операции Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 2.0 Россия Бухгалтерский учет Абонемент ($m)

Сокращение времени рутинных работ при импорте банковской выписки из Клиент-Банка в 1С: Бухгалтерию 3.0. Требования к файлу экспорта выписки: формат 1С: Предприятия для обмена с клиент-банками. Автоматическая разноска ключевых реквизитов документов: вид операции, корр.счет, субконто, контрагент. Приспосабливаемость к любым особенностям учета на предприятии. Подробное описание.

10 стартмани

24.11.2014    38378    120    Designer1C    9    

1С:Деньги: Загрузка выписки банка из личного кабинета Тинькофф Банка

Обмен с интернет-банком Учет доходов и расходов WEB-интеграция Платформа 1С v8.3 Конфигурации 1cv8 Домашние учет и финансы Управленческий учет Абонемент ($m)

Для тех, кто ведет домашние финансы в 1С:Деньги и пользуется услугами Тинькофф Банка. Расширение позволяет загружать операции из личного кабинета Тинькофф Банка напрямую, без промежуточных файлов.

1 стартмани

18.05.2020    11326    33    Bazil    27    

Автозагрузка банковских выписок (БП 3.0)

Банковские операции Обмен с интернет-банком Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Бухгалтерский учет Абонемент ($m)

Расширение позволяет автоматизировать загрузку банковских выписок в программу 1С:Бухгалтерия предприятия, ред. 3.0. При начальной настройке создается регламентное задание. Период срабатывания регламентного задания в дальнейшем можно поменять в консоли заданий. Требуется указать каталог, из которого нужно загружать банковские выписки.

10 стартмани

06.04.2020    13899    19    primat    25    

Выставление счета ссылкой на оплату через платежный шлюз Сбербанка из интерфейса 1С

Банковские операции Кассовые операции Оптовая торговля Розничная торговля Платформа 1С v7.7 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv7 Россия Абонемент ($m)

Внешняя обработка для выбора документа и формирования ссылки на оплату, которую можно скопировать в буфер обмена и отправить любыми средствами. Решение позволяет повысить автоматизацию процесса выставления счетов на оплату через интерфейс 1С8.х, 1С7.7. Совместимо с интернет-эквайрингом Сбербанк.

1 стартмани

14.01.2020    34590    155    etmarket    63    

Загрузка курсов валют на клиенте

БСП (Библиотека стандартных подсистем) Обработка справочников WEB-интеграция Банковские операции Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Абонемент ($m)

Расширение загрузки курсов валют НаКлиенте. Адаптивность стандартной обработки "ЗагрузитьКурсыВалют" для конфигураций, использующих БСП.

1 стартмани

07.12.2019    10411    11    logarifm    4    

1С:Деньги - Автоматическое заполнение расходов по QR-кодам чеков с помощью API ФНС

Обработка документов WEB-интеграция Банковские операции Кассовые операции Платформа 1С v8.3 Конфигурации 1cv8 Домашние учет и финансы Россия Управленческий учет Абонемент ($m)

UPDATE 2020.11 Учтено новое API взаимодействия с серверами проверки чеков ФНС. Реализована верификация по номеру телефона и кода из SMS. Обработка поможет сократить время на ввод данных о расходах в 1С:Деньги. Достаточно отсканировать QR-код чека смартфоном, с предустановленным официальным приложением проверки чеков от ФНС. Данные чека будут загружены в базу из данных электронного чека, которые хранятся на серверах ФНС. Обработка протестирована на последнем релизе 2.0.43.36.

1 стартмани

28.07.2019    19088    74    1sig    29    

Загрузка отчетов банка по эквайрингу в формате Excel (xls) (УТ11.4, КА2.4)

Загрузка и выгрузка в Excel Банковские операции Платформа 1С v8.3 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Бухгалтерский учет Абонемент ($m)

За основу была взята обработка с ИС. Но мне требовалось загрузить данные в КА2.4 и структура файла Excel была другой.

1 стартмани

01.07.2019    9832    87    dachnik    13    

Групповая печать чеков из банковской выписки (БП 3.0)

Пакетная печать Банковские операции Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Бухгалтерский учет Абонемент ($m)

Обработка для групповой печати чеков ККМ, загруженных из банковской выписки. На основании документа Поступление на расчетный счет от физических лиц.

3 стартмани

18.06.2019    17159    58    Doloris0    29    

Загрузка документов Отчет банка по эквайрингу в УТ 11.4 из Excel (Сбербанк)

Обработка документов Банковские операции Загрузка и выгрузка в Excel Обмен с интернет-банком Платформа 1С v8.3 1С:Управление торговлей 11 Россия Управленческий учет Абонемент ($m)

Обработка производит загрузку документов Отчет банка по эквайрингу из файла Excel, предоставляемого Сбербанком.

1 стартмани

10.10.2018    16904    89    C0mmander_Alex    13    

Загрузка табличной части документов "Ведомость в банк" или "Ведомость в кассу". ЗУП 3.1 из xls файла.

Обработка документов Загрузка и выгрузка в Excel Банковские операции Зарплата Кассовые операции Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и Управление Персоналом 3.x Бухгалтерский учет Абонемент ($m)

Загрузка \ заполнение табличной части документов "Ведомость в банк" "Ведомость на счета" или "Ведомость в кассу" ЗУП 3.1 из xls файла. Для работы обработки Excel устанавливать не надо. Работает во всех клиентах и вариантах работы, клиент-серверном, файловом и web.

2 стартмани

14.09.2018    17039    169    kg2    41    

[Расширение] Клиент-Банк. Выбор документов перед загрузкой в УТ 11.4

Обмен с интернет-банком Банковские операции Платформа 1С v8.3 1С:Управление торговлей 11 Управленческий учет Абонемент ($m)

Данное расширение позволяет отметить галочкой нужные документы из файла выгрузки банк-клиента и загрузить только их, не создавая лишние документы.

2 стартмани

24.07.2018    19694    198    ipetrochenko    76    

Выгрузка из ЗУП 3.1 в БП 2.0 документов на выплату зарплаты, отражения в учете. (Отражение зарплаты в бухучете, ведомость на выплату в банк, в кассу, через раздатчика, перечислением)

Обмен между базами 1C Банковские операции Зарплата Платформа 1С v8.3 1С:Бухгалтерия 2.0 1С:Зарплата и Управление Персоналом 3.x Бухгалтерский учет Абонемент ($m)

Позволит без труда выгрузить документы по отражению зарплаты и ведомости на выплату зарплаты из "Зарплата и Управление персоналом 3.1" в "Бухгалтерия предприятия 2.0"

3 стартмани

10.07.2018    24897    172    Redinternational    11